wpa_supplicant: supports only the real OpenSSL, not LibreSSL
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 17:03:08 +0000 (19:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 19:28:13 +0000 (21:28 +0200)
wpa_supplicant will not build with LibreSSL without patches, so let's
support only OpenSSL.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wpa_supplicant/wpa_supplicant.mk

index da757aaab09c9df06e45ac3d4127fc116ecfacf4..75ecbaa53c88c8d2a192a8f79da5d8289db95002 100644 (file)
@@ -97,8 +97,8 @@ WPA_SUPPLICANT_CONFIG_ENABLE += CONFIG_WPS
 endif
 
 # Try to use openssl if it's already available
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
-WPA_SUPPLICANT_DEPENDENCIES += openssl
+ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
+WPA_SUPPLICANT_DEPENDENCIES += libopenssl
 WPA_SUPPLICANT_LIBS += $(if $(BR2_STATIC_LIBS),-lcrypto -lz)
 WPA_SUPPLICANT_CONFIG_EDITS += 's/\#\(CONFIG_TLS=openssl\)/\1/'
 else