Applied patch from Brian Foster <brian.foster@innova-card.com>:
authorHamish Moffatt <hamish@cloud.net.au>
Thu, 11 Sep 2008 02:22:47 +0000 (02:22 -0000)
committerHamish Moffatt <hamish@cloud.net.au>
Thu, 11 Sep 2008 02:22:47 +0000 (02:22 -0000)
make "make clean" remove the .root stamp, so that everything will
be reinstalled properly on a subsequent build. (bug id 4304)
Also remove new autotools-stamps directory.

Makefile

index 1f9e7f6fe848086c384c80ad81f4f2e10ea6900b..d4463021556308b22a061785fcb8d8f3b5f7c673 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -358,10 +358,10 @@ external-deps:
 #
 #############################################################
 clean: $(TARGETS_CLEAN)
-       rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE)
+       rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE) $(PROJECT_BUILD_DIR)/.root $(PROJECT_BUILD_DIR)/autotools-stamps
 
 dirclean: $(TARGETS_DIRCLEAN)
-       rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE)
+       rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE) $(PROJECT_BUILD_DIR)/.root $(PROJECT_BUILD_DIR)/autotools-stamps
 
 distclean:
 ifeq ($(DL_DIR),$(BASE_DIR)/dl)