package/mpv: bump to version 0.32.0
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 20 Sep 2020 08:40:52 +0000 (10:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 20 Sep 2020 13:36:47 +0000 (15:36 +0200)
- Use github helper
- Drop first patch (not needed since version 0.30.0 and
  https://github.com/mpv-player/mpv/commit/9fd90c549c4022d7f9283adc1a97a076614c1458)
- vapoursynth-lazy has been dropped since version 0.30.0 and
  https://github.com/mpv-player/mpv/commit/fb8d240c4d045ca254aa6693c48aecc75954cba0
- mali-fbdev has been dropped since version 0.30.0 and
  https://github.com/mpv-player/mpv/commit/83d7123dc32e7fb8b1e05ed21af845707d115295
- libdvread has been dropped since version 0.30.0 and
  https://github.com/mpv-player/mpv/commit/62294049852549e99ec948e0df16452856afa0c1
- libv4l2 has been dropped since version 0.30. and
  https://github.com/mpv-player/mpv/commit/b30e85508a305d668db8419556d295a65ab08707
- Update indentation in hash file (two spaces)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpv/0001-fix-powerpc64-altivec.patch [new file with mode: 0644]
package/mpv/0001-wscript-don-t-check-for-fork-on-POSIX-checks.patch [deleted file]
package/mpv/0002-fix-powerpc64-altivec.patch [deleted file]
package/mpv/mpv.hash
package/mpv/mpv.mk

diff --git a/package/mpv/0001-fix-powerpc64-altivec.patch b/package/mpv/0001-fix-powerpc64-altivec.patch
new file mode 100644 (file)
index 0000000..45983fe
--- /dev/null
@@ -0,0 +1,32 @@
+Subject: [PATCH] Work around bool type redefinition by altivec
+
+On powerpc64le, the SDL header may include altivec.h and this
+(combined with -std=c99) will cause a compile failure due to bool
+being redefined as a vector type.
+
+Adjust the compiler flags to add -std=gnu99 (which is compatible with
+altivec) when using gcc. The generic flag '-std=c99' is left in place for other
+compilers (in the gcc case it is overridden by the (later) gnu flag).
+
+Signed-off-by: Sam Bobroff <sam.bobroff@au1.ibm.com>
+---
+ waftools/detections/compiler.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/waftools/detections/compiler.py b/waftools/detections/compiler.py
+index 5bbba87..50836a2 100644
+--- a/waftools/detections/compiler.py
++++ b/waftools/detections/compiler.py
+@@ -43,7 +43,8 @@ def __add_gcc_flags__(ctx):
+                        "-Wno-switch", "-Wparentheses", "-Wpointer-arith",
+                        "-Wno-pointer-sign",
+                        # GCC bug 66425
+-                       "-Wno-unused-result"]
++                       "-Wno-unused-result",
++                       "-std=gnu99"]
+ def __add_clang_flags__(ctx):
+     ctx.env.CFLAGS += ["-Wno-logical-op-parentheses", "-fcolor-diagnostics",
+-- 
+2.10.0.297.gf6727b0
+
diff --git a/package/mpv/0001-wscript-don-t-check-for-fork-on-POSIX-checks.patch b/package/mpv/0001-wscript-don-t-check-for-fork-on-POSIX-checks.patch
deleted file mode 100644 (file)
index 544c03c..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 61aea32efe675e584121295452fc7ab2a652d021 Mon Sep 17 00:00:00 2001
-From: Gustavo Zacarias <gustavo@zacarias.com.ar>
-Date: Wed, 20 Apr 2016 09:39:30 -0300
-Subject: [PATCH] wscript: don't check for fork() on POSIX checks
-
-It's not being used, and in fact prevents mpv from being built in nommu
-architectures (cortex M, blackfin, ...)
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
----
-Status: pull request https://github.com/mpv-player/mpv/pull/3068
-
- wscript | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/wscript b/wscript
-index a4ffce6..40328e4 100644
---- a/wscript
-+++ b/wscript
-@@ -127,7 +127,7 @@ main_dependencies = [
-         'desc': 'POSIX environment',
-         # This should be good enough.
-         'func': check_statement(['poll.h', 'unistd.h', 'sys/mman.h'],
--            'struct pollfd pfd; poll(&pfd, 1, 0); fork(); int f[2]; pipe(f); munmap(f,0)'),
-+            'struct pollfd pfd; poll(&pfd, 1, 0); int f[2]; pipe(f); munmap(f,0)'),
-     }, {
-         'name': 'posix-or-mingw',
-         'desc': 'development environment',
--- 
-2.7.3
-
diff --git a/package/mpv/0002-fix-powerpc64-altivec.patch b/package/mpv/0002-fix-powerpc64-altivec.patch
deleted file mode 100644 (file)
index 45983fe..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-Subject: [PATCH] Work around bool type redefinition by altivec
-
-On powerpc64le, the SDL header may include altivec.h and this
-(combined with -std=c99) will cause a compile failure due to bool
-being redefined as a vector type.
-
-Adjust the compiler flags to add -std=gnu99 (which is compatible with
-altivec) when using gcc. The generic flag '-std=c99' is left in place for other
-compilers (in the gcc case it is overridden by the (later) gnu flag).
-
-Signed-off-by: Sam Bobroff <sam.bobroff@au1.ibm.com>
----
- waftools/detections/compiler.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/waftools/detections/compiler.py b/waftools/detections/compiler.py
-index 5bbba87..50836a2 100644
---- a/waftools/detections/compiler.py
-+++ b/waftools/detections/compiler.py
-@@ -43,7 +43,8 @@ def __add_gcc_flags__(ctx):
-                        "-Wno-switch", "-Wparentheses", "-Wpointer-arith",
-                        "-Wno-pointer-sign",
-                        # GCC bug 66425
--                       "-Wno-unused-result"]
-+                       "-Wno-unused-result",
-+                       "-std=gnu99"]
- def __add_clang_flags__(ctx):
-     ctx.env.CFLAGS += ["-Wno-logical-op-parentheses", "-fcolor-diagnostics",
--- 
-2.10.0.297.gf6727b0
-
index 734b6a36636560f53416c00c99c6aff66383ce78..37db771356563c078dff4ba1198d4b72030cbaee 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 f9f9d461d1990f9728660b4ccb0e8cb5dce29ccaa6af567bec481b79291ca623 v0.29.1.tar.gz
-sha256 a99d7b0625a0566271aad6de694e52eafd566db024f9516720d526c680d3ee30 LICENSE.GPL
+sha256  9163f64832226d22e24bbc4874ebd6ac02372cd717bef15c28a0aa858c5fe592  mpv-0.32.0.tar.gz
+sha256  a99d7b0625a0566271aad6de694e52eafd566db024f9516720d526c680d3ee30  LICENSE.GPL
index 6801a0468f0219a8331b45d1eb45c62a3c8510d7..a7c9f7d74a4d321cf35e25b3b223d8ff9bf56692 100644 (file)
@@ -4,9 +4,8 @@
 #
 ################################################################################
 
-MPV_VERSION = 0.29.1
-MPV_SITE = https://github.com/mpv-player/mpv/archive
-MPV_SOURCE = v$(MPV_VERSION).tar.gz
+MPV_VERSION = 0.32.0
+MPV_SITE = $(call github,mpv-player,mpv,v$(MPV_VERSION))
 MPV_DEPENDENCIES = \
        host-pkgconf ffmpeg zlib \
        $(if $(BR2_PACKAGE_LIBICONV),libiconv)
@@ -27,9 +26,7 @@ MPV_CONF_OPTS = \
        --disable-rsound \
        --disable-rubberband \
        --disable-uchardet \
-       --disable-vapoursynth \
-       --disable-vapoursynth-lazy \
-       --disable-mali-fbdev
+       --disable-vapoursynth
 
 # ALSA support requires pcm+mixer
 ifeq ($(BR2_PACKAGE_ALSA_LIB_MIXER)$(BR2_PACKAGE_ALSA_LIB_PCM),yy)
@@ -112,14 +109,6 @@ else
 MPV_CONF_OPTS += --disable-dvdnav
 endif
 
-# libdvdread
-ifeq ($(BR2_PACKAGE_LIBDVDREAD),y)
-MPV_CONF_OPTS += --enable-dvdread
-MPV_DEPENDENCIES += libdvdread
-else
-MPV_CONF_OPTS += --disable-dvdread
-endif
-
 # libdrm
 ifeq ($(BR2_PACKAGE_LIBDRM),y)
 MPV_CONF_OPTS += --enable-drm
@@ -128,16 +117,6 @@ else
 MPV_CONF_OPTS += --disable-drm
 endif
 
-# libv4l
-ifeq ($(BR2_PACKAGE_LIBV4L),y)
-MPV_CONF_OPTS += \
-       --enable-libv4l2 \
-       --enable-tv
-MPV_DEPENDENCIES += libv4l
-else
-MPV_CONF_OPTS += --disable-libv4l2
-endif
-
 # libvdpau
 ifeq ($(BR2_PACKAGE_LIBVDPAU),y)
 MPV_CONF_OPTS += --enable-vdpau