package/thttpd: fix systemd startup
authorCarlos Santos <unixmania@gmail.com>
Wed, 28 Aug 2019 02:16:25 +0000 (23:16 -0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 15 Sep 2019 13:19:05 +0000 (15:19 +0200)
Create the configuration file as /etc/thttpd.conf, as expected by the
systemd unit file.

This matches other web server packages that install configuration files
at /etc/lighttpd/, /etc/apache2, etc.

Signed-off-by: Carlos Santos <unixmania@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/thttpd/thttpd.mk

index a028e48cb4eee02dc4ebfd3166bcbff95a007a79..6cf86e4b95925afd822c36375d098de4d6d4b2c4 100644 (file)
@@ -18,13 +18,14 @@ define THTTPD_INSTALL_TARGET_CMDS
        $(INSTALL) -D -m 0755 $(@D)/extras/syslogtocern $(TARGET_DIR)/usr/bin/syslogtocern
        $(INSTALL) -D -m 0755 $(@D)/scripts/thttpd_wrapper $(TARGET_DIR)/usr/sbin/thttpd_wrapper
        $(SED) 's:/usr/local/sbin:/usr/sbin:g' -e \
-               's:/usr/local/www:/var/www:g' $(TARGET_DIR)/usr/sbin/thttpd_wrapper
+               's:/usr/local/www/thttpd_config:/etc/thttpd.conf:g' \
+               $(TARGET_DIR)/usr/sbin/thttpd_wrapper
        $(INSTALL) -d $(TARGET_DIR)/var/www/data
        $(INSTALL) -d $(TARGET_DIR)/var/www/logs
-       echo "dir=/var/www/data" > $(TARGET_DIR)/var/www/thttpd_config
-       echo 'cgipat=**.cgi' >> $(TARGET_DIR)/var/www/thttpd_config
-       echo "logfile=/var/www/logs/thttpd_log" >> $(TARGET_DIR)/var/www/thttpd_config
-       echo "pidfile=/var/run/thttpd.pid" >> $(TARGET_DIR)/var/www/thttpd_config
+       echo "dir=/var/www/data" > $(TARGET_DIR)/etc/thttpd.conf
+       echo 'cgipat=**.cgi' >> $(TARGET_DIR)/etc/thttpd.conf
+       echo "logfile=/var/www/logs/thttpd_log" >> $(TARGET_DIR)/etc/thttpd.conf
+       echo "pidfile=/var/run/thttpd.pid" >> $(TARGET_DIR)/etc/thttpd.conf
 endef
 
 define THTTPD_INSTALL_INIT_SYSV