libfslcodec: Use self-extractible helper
authorJérôme Pouiller <jezz@sysmic.org>
Wed, 19 Nov 2014 21:30:37 +0000 (22:30 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 27 Nov 2014 21:00:17 +0000 (22:00 +0100)
[Thomas: remove unneeded comment.]

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libfslcodec/libfslcodec.mk

index 1a364bb7db44ab8577f5ad429958db3443902fff..fe6f0ba5020e6c553f6b1cae2bc79660bdb0ae59 100644 (file)
@@ -7,30 +7,14 @@
 LIBFSLCODEC_VERSION = 3.0.11
 LIBFSLCODEC_SITE = $(FREESCALE_IMX_SITE)
 LIBFSLCODEC_SOURCE = libfslcodec-$(LIBFSLCODEC_VERSION).bin
+LIBFSLCODEC_INSTALL_STAGING = YES
+
 LIBFSLCODEC_LICENSE = Freescale Semiconductor Software License Agreement, BSD-3c (flac, ogg headers)
 LIBFSLCODEC_LICENSE_FILES = EULA EULA.txt
-# This is a legal minefield: the EULA in the bin file specifies that
-# the Board Support Package includes software and hardware (sic!)
-# for which a separate license is needed...
 LIBFSLCODEC_REDISTRIBUTE = NO
 
-LIBFSLCODEC_INSTALL_STAGING = YES
-
-# The archive is a shell-self-extractor of a bzipped tar. It happens
-# to extract in the correct directory (libfslcodec-x.y.z)
-# The --force makes sure it doesn't fail if the source dir already exists.
-# The --auto-accept skips the license check - not needed for us
-# because we have legal-info.
-# Since the EULA in the bin file differs from the one in the tar file,
-# extract the one from the bin file as well.
 define LIBFSLCODEC_EXTRACT_CMDS
-       awk 'BEGIN      { start=0; } \
-            /^EOEULA/  { start = 0; } \
-                       { if (start) print; } \
-            /<<EOEULA/ { start=1; }'\
-           $(DL_DIR)/$(LIBFSLCODEC_SOURCE) > $(@D)/EULA
-       cd $(BUILD_DIR); \
-       sh $(DL_DIR)/$(LIBFSLCODEC_SOURCE) --force --auto-accept
+       $(call FREESCALE_IMX_EXTRACT_HELPER,$(DL_DIR)/$(LIBFSLCODEC_SOURCE))
 endef
 
 # FIXME The Makefile installs both the arm9 and arm11 versions of the