luajit: Disable for MIPS architecture with soft-float
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Wed, 9 Apr 2014 13:40:55 +0000 (14:40 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 10 Apr 2014 20:44:14 +0000 (22:44 +0200)
Currently luajit is not supported on MIPS soft-float userlands. Upstream
plans to support it in the future:

   http://wiki.luajit.org/Open-Sponsorships#MIPS-Soft-Float-and-Dual-Number-Port

Fixes:

   http://autobuild.buildroot.net/results/d52/d5232a215e9e9aeb40b2e4e353329a27603c79ab/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/luajit/Config.in

index 58b165381fca4697ecd4402df9dc6f1d366160c2..5176cb864d78edffea95c062abb50c975d96ea51 100644 (file)
@@ -3,7 +3,8 @@ config BR2_PACKAGE_LUAJIT
        select BR2_PACKAGE_HAS_LUAINTERPRETER
        # Luajit is only available for some target architectures, and
        # has some complexity wrt 32/64. See luajit.mk for details.
-       depends on BR2_i386 || (BR2_x86_64 && BR2_HOSTARCH='x86_64') || BR2_powerpc || BR2_arm || BR2_armeb || BR2_mips || BR2_mipsel
+       depends on BR2_i386 || (BR2_x86_64 && BR2_HOSTARCH='x86_64') || BR2_powerpc || BR2_arm || BR2_armeb \
+                  || ((BR2_mips || BR2_mipsel) && !BR2_MIPS_SOFT_FLOAT)
        help
          LuaJIT implements the full set of language features defined
          by Lua 5.1. The virtual machine (VM) is API- and