Prevent libtool patching before autoreconf when autoreconf is required
authorLionel Landwerlin <lionel.landwerlin@openwide.fr>
Sun, 4 Oct 2009 18:41:55 +0000 (20:41 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 5 Oct 2009 12:11:49 +0000 (14:11 +0200)
Signed-off-by: Lionel Landwerlin <lionel.landwerlin@openwide.fr>
Tested-By: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.autotools.in

index c4c4b1cebc7587ba667c2c08ca6cce9e120d8138..d36c884f05e563272046b4fe92db1746c75d7119 100644 (file)
@@ -188,7 +188,8 @@ $(BUILD_DIR)/%/.stamp_extracted:
 $(BUILD_DIR)/%/.stamp_libtool_patch:
        $(call MESSAGE,"Patching libtool")
 # if the package uses libtool, patch it for cross-compiling in buildroot
-       $(Q)if test "$($(PKG)_LIBTOOL_PATCH)" = "YES"; then \
+       $(Q)if test "$($(PKG)_LIBTOOL_PATCH)" = "YES" -a \
+       "$($(PKG)_AUTORECONF)" != "YES"; then \
        for i in `find $(@D) -name ltmain.sh`; do \
                toolchain/patch-kernel.sh $${i%/*} package buildroot-libtool.patch; \
                done \