package/prboom: avoid using hardcoded optimization flags
authorGiulio Benetti <giulio.benetti@micronovasrl.com>
Wed, 26 Jun 2019 12:58:58 +0000 (14:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 3 Aug 2019 10:57:46 +0000 (12:57 +0200)
Package prboom builds using -O2 flag ignoring Buildroot settings, this
is due to the fact that -O2 is appended at the end of compiler flags.

Remove -O2 from 'configure.ac' file and set PRBOOM_AUTORECONF to YES,
this way CFLAGS_OPTS will contain Buildroot TARGET_CFLAGS.

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/prboom/0002-configure-remove-predefined-O2-optimization-flag.patch [new file with mode: 0644]
package/prboom/prboom.mk

diff --git a/package/prboom/0002-configure-remove-predefined-O2-optimization-flag.patch b/package/prboom/0002-configure-remove-predefined-O2-optimization-flag.patch
new file mode 100644 (file)
index 0000000..9260cb6
--- /dev/null
@@ -0,0 +1,21 @@
+configure: remove predefined -O2 optimization flag
+
+CFLAGS_OPT variable forces to use -O2 optimization flag denying the
+possibility to use different optimization flag values.
+
+Remove -O2 flag from CFLAGS_OPT.
+
+Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
+---
+diff -urpN prboom-2.5.0.orig/configure.ac prboom-2.5.0/configure.ac
+--- prboom-2.5.0.orig/configure.ac     2019-06-20 14:07:45.058481879 +0200
++++ prboom-2.5.0/configure.ac  2019-06-20 14:09:05.066238825 +0200
+@@ -48,7 +48,7 @@ else
+ fi
+ dnl --- cph: work out flags to pass to compiler
+-CFLAGS_OPT="-O2 -fomit-frame-pointer"
++CFLAGS_OPT="-fomit-frame-pointer"
+ AC_C_COMPILE_FLAGS(-Wall)
+ dnl --- Option to enable debugging
+ AC_ARG_ENABLE(debug,AC_HELP_STRING([--enable-debug],[turns on various debugging features, like range checking and internal heap diagnostics]),,enable_debug="no")
index d370ae3fa5e217d7bff7abc619bd21850189d0f6..325bf3eb0247e2c2fdf223b5d45febf4453664b6 100644 (file)
@@ -10,6 +10,7 @@ PRBOOM_CONF_ENV = ac_cv_type_uid_t=yes
 PRBOOM_DEPENDENCIES = sdl sdl_net sdl_mixer
 PRBOOM_LICENSE = GPL-2.0+
 PRBOOM_LICENSE_FILES = COPYING
+PRBOOM_AUTORECONF = YES
 
 ifeq ($(BR2_PACKAGE_LIBPNG),y)
 PRBOOM_DEPENDENCIES += libpng