syslinux: use Git formatted patches
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 5 Apr 2017 20:06:06 +0000 (22:06 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 5 Apr 2017 20:06:06 +0000 (22:06 +0200)
In preparation for the addition of more patches to the syslinux
package, reformat the two existing patches as proper Git formatted
patches.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/syslinux/0001-Fix-gcc-5-ALIGN-causing-Boot-error.patch [deleted file]
boot/syslinux/0001-bios-Fix-alignment-change-with-gcc-5.patch [new file with mode: 0644]
boot/syslinux/0002-Disable-PIE-to-avoid-FTBFS-on-amd64.patch [new file with mode: 0644]
boot/syslinux/0002-disable-pie.patch [deleted file]

diff --git a/boot/syslinux/0001-Fix-gcc-5-ALIGN-causing-Boot-error.patch b/boot/syslinux/0001-Fix-gcc-5-ALIGN-causing-Boot-error.patch
deleted file mode 100644 (file)
index 2df6766..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
-commit e5f2b577ded109291c9632dacb6eaa621d8a59fe
-Author: Sylvain Gault <sylvain.gault@gmail.com>
-Date:   Tue Sep 29 02:38:25 2015 +0200
-
-    bios: Fix alignment change with gcc 5
-    
-    The section aligment specified in the ld scripts have to be greater or
-    equal to those in the .o files generated by gcc.
-    
-    Signed-off-by: Sylvain Gault <sylvain.gault@gmail.com>
-    Tested-by: poma <pomidorabelisima@gmail.com>
-    Signed-off-by: Paulo Alcantara <pcacjr@zytor.com>
-    Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
-
-diff --git a/core/i386/syslinux.ld b/core/i386/syslinux.ld
-index 7b4e012..7390451 100644
---- a/core/i386/syslinux.ld
-+++ b/core/i386/syslinux.ld
-@@ -266,7 +266,7 @@ SECTIONS
-               __text_end = .;
-       }
--      . = ALIGN(16);
-+      . = ALIGN(32);
-       __rodata_vma = .;
-       __rodata_lma = __rodata_vma + __text_lma - __text_vma;
-@@ -361,7 +361,7 @@ SECTIONS
-               __dynamic_end = .;
-       }
--      . = ALIGN(16);
-+      . = ALIGN(32);
-       __data_vma = .;
-       __data_lma = __data_vma + __text_lma - __text_vma;
-@@ -377,7 +377,7 @@ SECTIONS
-       __pm_code_dwords = (__pm_code_len + 3) >> 2;
-       . = ALIGN(128);
--      
-+
-       __bss_vma = .;
-       __bss_lma = .;          /* Dummy */
-       .bss (NOLOAD) : AT (__bss_lma) {
-diff --git a/core/x86_64/syslinux.ld b/core/x86_64/syslinux.ld
-index 1057112..bf815c4 100644
---- a/core/x86_64/syslinux.ld
-+++ b/core/x86_64/syslinux.ld
-@@ -266,7 +266,7 @@ SECTIONS
-               __text_end = .;
-       }
--      . = ALIGN(16);
-+      . = ALIGN(32);
-       __rodata_vma = .;
-       __rodata_lma = __rodata_vma + __text_lma - __text_vma;
-@@ -361,7 +361,7 @@ SECTIONS
-               __dynamic_end = .;
-       }
--      . = ALIGN(16);
-+      . = ALIGN(32);
-       __data_vma = .;
-       __data_lma = __data_vma + __text_lma - __text_vma;
-@@ -377,7 +377,7 @@ SECTIONS
-       __pm_code_dwords = (__pm_code_len + 3) >> 2;
-       . = ALIGN(128);
--      
-+
-       __bss_vma = .;
-       __bss_lma = .;          /* Dummy */
-       .bss (NOLOAD) : AT (__bss_lma) {
diff --git a/boot/syslinux/0001-bios-Fix-alignment-change-with-gcc-5.patch b/boot/syslinux/0001-bios-Fix-alignment-change-with-gcc-5.patch
new file mode 100644 (file)
index 0000000..633d996
--- /dev/null
@@ -0,0 +1,82 @@
+From da5cbd1a3b248f2d32281a1766a3d1414c0e8e03 Mon Sep 17 00:00:00 2001
+From: Sylvain Gault <sylvain.gault@gmail.com>
+Date: Tue, 29 Sep 2015 02:38:25 +0200
+Subject: [PATCH] bios: Fix alignment change with gcc 5
+
+The section aligment specified in the ld scripts have to be greater or
+equal to those in the .o files generated by gcc.
+
+Signed-off-by: Sylvain Gault <sylvain.gault@gmail.com>
+Tested-by: poma <pomidorabelisima@gmail.com>
+Signed-off-by: Paulo Alcantara <pcacjr@zytor.com>
+Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
+---
+ core/i386/syslinux.ld   | 6 +++---
+ core/x86_64/syslinux.ld | 6 +++---
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/core/i386/syslinux.ld b/core/i386/syslinux.ld
+index 7b4e012..7390451 100644
+--- a/core/i386/syslinux.ld
++++ b/core/i386/syslinux.ld
+@@ -266,7 +266,7 @@ SECTIONS
+               __text_end = .;
+       }
+-      . = ALIGN(16);
++      . = ALIGN(32);
+       __rodata_vma = .;
+       __rodata_lma = __rodata_vma + __text_lma - __text_vma;
+@@ -361,7 +361,7 @@ SECTIONS
+               __dynamic_end = .;
+       }
+-      . = ALIGN(16);
++      . = ALIGN(32);
+       __data_vma = .;
+       __data_lma = __data_vma + __text_lma - __text_vma;
+@@ -377,7 +377,7 @@ SECTIONS
+       __pm_code_dwords = (__pm_code_len + 3) >> 2;
+       . = ALIGN(128);
+-      
++
+       __bss_vma = .;
+       __bss_lma = .;          /* Dummy */
+       .bss (NOLOAD) : AT (__bss_lma) {
+diff --git a/core/x86_64/syslinux.ld b/core/x86_64/syslinux.ld
+index 1057112..bf815c4 100644
+--- a/core/x86_64/syslinux.ld
++++ b/core/x86_64/syslinux.ld
+@@ -266,7 +266,7 @@ SECTIONS
+               __text_end = .;
+       }
+-      . = ALIGN(16);
++      . = ALIGN(32);
+       __rodata_vma = .;
+       __rodata_lma = __rodata_vma + __text_lma - __text_vma;
+@@ -361,7 +361,7 @@ SECTIONS
+               __dynamic_end = .;
+       }
+-      . = ALIGN(16);
++      . = ALIGN(32);
+       __data_vma = .;
+       __data_lma = __data_vma + __text_lma - __text_vma;
+@@ -377,7 +377,7 @@ SECTIONS
+       __pm_code_dwords = (__pm_code_len + 3) >> 2;
+       . = ALIGN(128);
+-      
++
+       __bss_vma = .;
+       __bss_lma = .;          /* Dummy */
+       .bss (NOLOAD) : AT (__bss_lma) {
+-- 
+2.7.4
+
diff --git a/boot/syslinux/0002-Disable-PIE-to-avoid-FTBFS-on-amd64.patch b/boot/syslinux/0002-Disable-PIE-to-avoid-FTBFS-on-amd64.patch
new file mode 100644 (file)
index 0000000..64a08b8
--- /dev/null
@@ -0,0 +1,30 @@
+From 250bf2c921713434627dc7bc8b0918fa0841f9b7 Mon Sep 17 00:00:00 2001
+From: Graham Inggs <ginggs@ubuntu.com>
+Date: Wed, 5 Apr 2017 22:03:12 +0200
+Subject: [PATCH] Disable PIE to avoid FTBFS on amd64
+
+gcc 6.x has PIE support enabled by default, which causes a build issue
+with syslinux. This patch disables PIE support in the relevant
+syslinux Makefile.
+
+Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
+---
+ gpxe/src/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gpxe/src/Makefile b/gpxe/src/Makefile
+index cc91d78..077af64 100644
+--- a/gpxe/src/Makefile
++++ b/gpxe/src/Makefile
+@@ -4,7 +4,7 @@
+ #
+ CLEANUP               :=
+-CFLAGS                :=
++CFLAGS                := -fno-PIE
+ ASFLAGS               :=
+ LDFLAGS               :=
+ MAKEDEPS      := Makefile
+-- 
+2.7.4
+
diff --git a/boot/syslinux/0002-disable-pie.patch b/boot/syslinux/0002-disable-pie.patch
deleted file mode 100644 (file)
index b31b622..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-Description: Disable PIE to avoid FTBFS on amd64
-Bug-Ubuntu: https://bugs.launchpad.net/bugs/1579023
-Author: Graham Inggs <ginggs@ubuntu.com>
-Last-Update: 2016-05-06
-
-gcc 6.x has PIE support enabled by default, which causes a build issue
-with syslinux. This patch disables PIE support in the relevant
-syslinux Makefile.
-
-Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
-
---- a/gpxe/src/Makefile
-+++ b/gpxe/src/Makefile
-@@ -4,7 +4,7 @@
- #
-
- CLEANUP               :=
--CFLAGS                :=
-+CFLAGS                := -fno-PIE
- ASFLAGS               :=
- LDFLAGS               :=
- MAKEDEPS      := Makefile