git: needs libiconv on toolchains without locale support
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 3 Jun 2013 20:52:24 +0000 (22:52 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 3 Jun 2013 20:52:24 +0000 (22:52 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/git/Config.in
package/git/git.mk

index dc342aa7bbaee7575c5ae6b09054af326cf9279e..931d460d4fc52592db66e1a9a2ab3c3c973dd50d 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_GIT
        bool "git"
        depends on BR2_LARGEFILE
        select BR2_PACKAGE_ZLIB
+       select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        help
          Git is a free and open source distributed version control system
          designed to handle everything from small to very large projects.
index 6bc9761493a364480541481c2c61b1786ba16d92..7e2f114be0349d74d3b2d24d7deb432a0122afa4 100644 (file)
@@ -40,6 +40,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_LIBICONV),y)
        GIT_DEPENDENCIES += libiconv
+       GIT_CONF_ENV += LIBS=-liconv
        GIT_CONF_OPT += --with-iconv=/usr/lib
 else
        GIT_CONF_OPT += --without-iconv
@@ -54,7 +55,7 @@ endif
 
 # assume yes for these tests, configure will bail out otherwise
 # saying error: cannot run test program while cross compiling
-GIT_CONF_ENV =         ac_cv_fread_reads_directories=yes \
+GIT_CONF_ENV += ac_cv_fread_reads_directories=yes \
        ac_cv_snprintf_returns_bogus=yes
 
 $(eval $(autotools-package))