vlc: select libvorbis when opus is also selected
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Mon, 14 Apr 2014 14:20:07 +0000 (15:20 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Apr 2014 18:53:56 +0000 (20:53 +0200)
If BR2_PACKAGE_OPUS is selected then vlc will be built with support for
opus passing "--enable-opus" option to the configure script. But when
the configure script checks for the opus library it also checks for the
ogg library at the same time, so if only opus has been installed and not
ogg, then it will fail with an error message like this one:

checking for OPUS... no
configure: error: Library ogg opus needed for opus was not found

Fixes:
   http://autobuild.buildroot.net/results/4da/4da8e7cfb35c351e5d623835118512248d331d16/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vlc/Config.in
package/vlc/vlc.mk

index b7c6088a6821e45411cbe9d19daaa057217eacf8..cdb0d1642d2948c158cae966199b19acc244538d 100644 (file)
@@ -10,6 +10,7 @@ config BR2_PACKAGE_VLC
        depends on BR2_LARGEFILE
        depends on BR2_USE_WCHAR
        depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_LIBVORBIS if BR2_PACKAGE_OPUS
        help
          VLC is a free and open source cross-platform multimedia player
          and framework that plays most multimedia files as well as DVD,
index a9ee62015a516e66ea0c41a5a39fab2de1f799d0..bcb592cdb6607938409a494f81c4ab4b243f87e1 100644 (file)
@@ -127,7 +127,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_OPUS),y)
 VLC_CONF_OPT += --enable-opus
-VLC_DEPENDENCIES += opus
+VLC_DEPENDENCIES += libvorbis opus
 else
 VLC_CONF_OPT += --disable-opus
 endif