nftables: fix build in static scenarios
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 16 Aug 2014 13:35:47 +0000 (15:35 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 17 Aug 2014 07:10:12 +0000 (09:10 +0200)
When linking against readline, it forgets to link against ncurses,
which is needed by readline. Fix this by passing LIBS="-lcurses" to
the configure script.

Fixes:

  http://autobuild.buildroot.org/results/98b/98b707ffdeeb1cda94b7c1019ef29cf5fd7db8bf/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/nftables/nftables.mk

index b25e8f246cdc2ad5549efc656e19c9219c9e1424..b3abbc0dd9a954c988d92c0cb06bda94287b131b 100644 (file)
@@ -12,6 +12,8 @@ NFTABLES_DEPENDENCIES = gmp libmnl libnftnl readline host-bison host-flex \
 NFTABLES_LICENSE = GPLv2
 NFTABLES_LICENSE_FILES = COPYING
 
-NFTABLES_CONF_ENV = ac_cv_prog_CONFIG_PDF=no
+NFTABLES_CONF_ENV = \
+       ac_cv_prog_CONFIG_PDF=no \
+       LIBS="-lncurses"
 
 $(eval $(autotools-package))