package/xen: add upstream xsa-36{0, 4, 8} security fixes
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 5 Apr 2021 19:17:53 +0000 (21:17 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 6 Apr 2021 07:38:31 +0000 (09:38 +0200)
Fixes the following security issues:

- CVE-2021-3308: IRQ vector leak on x86
  https://xenbits.xenproject.org/xsa/advisory-360.html

- CVE-2021-26933: arm: The cache may not be cleaned for newly allocated
  scrubbed pages
  https://xenbits.xenproject.org/xsa/advisory-364.html

- CVE-2021-28687: HVM soft-reset crashes toolstack
  https://xenbits.xenproject.org/xsa/advisory-368.html

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/xen/xen.hash
package/xen/xen.mk

index 95061c3fc8f279974cd073ad50fcb84dd9d3d986..6893414313463977b7e05bd918181aff811566db 100644 (file)
@@ -1,3 +1,9 @@
 # Locally computed
 sha256  cf0d7316ad674491f49b7ef0518cb1d906a2e3bfad639deef0ef2343b119ac0c  xen-4.14.1.tar.gz
 sha256  ecca9538e9d3f7e3c2bff827502f4495e2ef9e22c451298696ea08886b176c2c  COPYING
+# https://xenbits.xenproject.org/xsa/advisory-360.html
+sha256  809515011efb781a2a8742e9acfd76412d3920c2d4142bb187588cd36f77383e  xsa360-4.14.patch
+# https://xenbits.xenproject.org/xsa/advisory-364.html
+sha256  dc313c70bb07b4096bbc4612cbbc180589923277411dede2fda37f04ecc846d6  xsa364.patch
+# https://xenbits.xenproject.org/xsa/advisory-368.html
+sha256  55bbe59c75b69f493e364dfcf6cdbc7db4acd32dbf0b4d2466815b7c1f1823ce  xsa368-4.14.patch
index 3a758b7b20befce57fa3270cef156409334d2c6c..533882e05b5703d58b99eb4bf63038bf5d9b90c4 100644 (file)
@@ -11,6 +11,19 @@ XEN_LICENSE_FILES = COPYING
 XEN_CPE_ID_VENDOR = xen
 XEN_CPE_ID_PREFIX = cpe:2.3:o
 XEN_DEPENDENCIES = host-acpica host-python3
+XEN_PATCH = \
+       https://xenbits.xenproject.org/xsa/xsa360-4.14.patch \
+       https://xenbits.xenproject.org/xsa/xsa364.patch \
+       https://xenbits.xenproject.org/xsa/xsa368-4.14.patch
+
+# xsa360-4.14.patch
+XEN_IGNORE_CVES += CVE-2021-3308
+
+# xsa364.patch
+XEN_IGNORE_CVES += CVE-2021-26933
+
+# xsa368-4.14.patch
+XEN_IGNORE_CVES += CVE-2021-28687
 
 # Calculate XEN_ARCH
 ifeq ($(ARCH),aarch64)