bash: minor install tweaks
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 8 Oct 2014 13:19:47 +0000 (10:19 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 8 Oct 2014 17:28:34 +0000 (19:28 +0200)
Remove the old symlink backup since we don't do uninstalls now.
Make the busybox dependency conditional shorter.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/bash/bash.mk

index acd64f14d02e3f35722faf26495feb3f89db02cf..6510af5e9cbea79cd2721ae49a3320995f006cfe 100644 (file)
@@ -6,7 +6,9 @@
 
 BASH_VERSION = 4.3
 BASH_SITE = $(BR2_GNU_MIRROR)/bash
-BASH_DEPENDENCIES = ncurses readline host-bison
+# Build after since bash is better than busybox shells
+BASH_DEPENDENCIES = ncurses readline host-bison \
+       $(if $(BR2_PACKAGE_BUSYBOX),busybox)
 BASH_CONF_OPTS = --with-installed-readline
 BASH_LICENSE = GPLv3+
 BASH_LICENSE_FILES = COPYING
@@ -28,19 +30,11 @@ ifeq ($(BR2_PREFER_STATIC_LIB),y)
 BASH_CONF_OPTS += --enable-static-link --without-bash-malloc
 endif
 
-# Make sure we build after busybox so that /bin/sh links to bash
-ifeq ($(BR2_PACKAGE_BUSYBOX),y)
-BASH_DEPENDENCIES += busybox
-endif
-
-# Save the old sh file/link if there is one and symlink bash->sh
+# Make /bin/sh -> bash (no other shell, better than busybox shells)
 define BASH_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
                DESTDIR=$(TARGET_DIR) exec_prefix=/ install
        rm -f $(TARGET_DIR)/bin/bashbug
-       if [ -e $(TARGET_DIR)/bin/sh ]; then \
-               mv -f $(TARGET_DIR)/bin/sh $(TARGET_DIR)/bin/sh.prebash; \
-       fi
        ln -sf bash $(TARGET_DIR)/bin/sh
 endef