package/sdl: fix dependencies for directfb/qt/x11 support
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 22 Nov 2009 20:03:42 +0000 (21:03 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 22 Nov 2009 20:03:42 +0000 (21:03 +0100)
Closes #683

And cleanup Kconfig while we're at it.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/sdl/Config.in
package/sdl/sdl.mk

diff --git a/CHANGES b/CHANGES
index 37931d861663faae329976997982e91f593e0258..ab1df38ec7003291d6c90addafee6bb71f866167 100644 (file)
--- a/CHANGES
+++ b/CHANGES
        gst-plugins-good, imagemagick, ipkg, iptables, iw, kernel-headers,
        kismet, libelf, libevent, libglib2, libidn, liblockfile, libmad,
        libpcap, libupnp, libuuid, lighttpd, ltrace, lua, lzma, mdadm, ncftp,
-       ncurses, netkittelnet, netsnmp, ntfs-3g, openntp, openssl, php, python,
-       quagga, radvd, rsync, samba, sawman, shared-mime-info, spawn-fcgi,
-       speech-tools, sqlite, squashfs, synergy, syslinux, tcpdump, u-boot,
-       util-linux, valgrind, vsftpd, wipe
+       ncurses, netkittelnet, netsnmp, ntfs-3g, openntp, openssl, php,
+       python, quagga, radvd, rsync, samba, sawman, sdl, shared-mime-info,
+       spawn-fcgi, speech-tools, sqlite, squashfs, synergy, syslinux,
+       tcpdump, u-boot, util-linux, valgrind, vsftpd, wipe
 
        wpa-supplicant, xdata_xcursor-themes, zlib
 
@@ -44,6 +44,7 @@
        #657: Bug in imagemagick-clean target
        #665: [PATCH] Samba package
        #667: [PATCH] e2fsprogs
+       #683: SDL-dfb does not select directfb
        #701: make install problem with unstripped binaries
        #703: [SECURITY] Update openssl package to 0.9.8l
        #705: Bump spawn-fcgi package to 1.6.3
index 7cba524f34fb3a272af92f1ba5c6fcbdd0681755..869173d88f8e7ee251f1b37679de9397b783fc6b 100644 (file)
@@ -1,11 +1,13 @@
 config BR2_PACKAGE_SDL
        bool "SDL"
        help
+         Simple DirectMedia Layer - SDL is a library that allows
+         programs portable low level access to a video framebuffer,
+         audio output, mouse, and keyboard.
 
          http://www.libsdl.org/
 
-menu "SDL options selection"
-       depends on BR2_PACKAGE_SDL
+if BR2_PACKAGE_SDL
 
 config BR2_PACKAGE_SDL_FBCON
        bool "SDL framebuffer console video driver"
@@ -13,11 +15,14 @@ config BR2_PACKAGE_SDL_FBCON
 
 config BR2_PACKAGE_SDL_DIRECTFB
        bool "SDL DirectFB video driver"
+       depends on BR2_PACKAGE_DIRECTFB
 
 config BR2_PACKAGE_SDL_QTOPIA
        bool "SDL Qtopia video driver"
+       depends on BR2_PACKAGE_QT
 
 config BR2_PACKAGE_SDL_X11
        bool "SDL X11 video driver"
+       depends on BR2_PACKAGE_XORG7
 
-endmenu
+endif
index e9d6c0cd0570ab8dfa7a742cfcd592af74d99b84..f66ecc4f1299db613c7d824019a2e0e90f79810a 100644 (file)
@@ -18,6 +18,7 @@ SDL_FBCON=--enable-video-fbcon=no
 endif
 
 ifeq ($(BR2_PACKAGE_SDL_DIRECTFB),y)
+SDL_DEPENDENCIES += directfb
 SDL_DIRECTFB=--enable-video-directfb=yes
 SDL_DIRECTFB_TARGET:=$(STAGING_DIR)/include/directfb
 SDL_DIRECTFB_INCLUDES:=-I$(STAGING_DIR)/usr/include/directfb
@@ -28,12 +29,14 @@ endif
 
 ifeq ($(BR2_PACKAGE_SDL_QTOPIA),y)
 SDL_QTOPIA=--enable-video-qtopia=yes
+SDL_DEPENDENCIES += qt
 else
 SDL_QTOPIA=--enable-video-qtopia=no
 endif
 
 ifeq ($(BR2_PACKAGE_SDL_X11),y)
 SDL_X11=--enable-video-x11=yes
+SDL_DEPENDENCIES += xserver_xorg-server
 else
 SDL_X11=--enable-video-x11=no
 endif
@@ -96,7 +99,7 @@ $(TARGET_DIR)/usr/lib/libSDL.so: $(STAGING_DIR)/usr/lib/libSDL.so
        cp -dpf $(STAGING_DIR)/usr/lib/libSDL*.so* $(TARGET_DIR)/usr/lib/
        -$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libSDL.so
 
-SDL sdl: $(TARGET_DIR)/usr/lib/libSDL.so
+SDL sdl: $(SDL_DEPENDENCIES) $(TARGET_DIR)/usr/lib/libSDL.so
 
 sdl-unpacked: $(SDL_DIR)/.unpacked