Ensure AVR32 FPU config is always correct
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Tue, 23 Oct 2007 09:49:56 +0000 (09:49 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Tue, 23 Oct 2007 09:49:56 +0000 (09:49 -0000)
target/Config.in.arch
toolchain/Config.in.2
toolchain/gcc/Makefile.in

index d764b62dd0cf8a29c7b0479c7114f0a56f90a142..bd950c8a423b8c515a1a1af640c98fd451d40276 100644 (file)
@@ -12,6 +12,8 @@ config BR2_armeb
        bool "armeb"
 config BR2_avr32
        bool "avr32"
+       select BR2_SOFT_FLOAT
+
 config BR2_cris
        bool "cris"
 config BR2_ia64
index d3a1a19452f7e8bda8c58a8801a2da15fe28a0b5..244fcf108969d06061632c77ce869fcf5debf5bc 100644 (file)
@@ -48,7 +48,7 @@ config BR2_USE_WCHAR
 config BR2_SOFT_FLOAT
        bool "Use software floating point by default"
        default n
-       depends on BR2_arm || BR2_armeb || BR2_mips || BR2_mipsel || BR2_powerpc
+       depends on BR2_arm || BR2_armeb || BR2_avr32 || BR2_mips || BR2_mipsel || BR2_powerpc
        help
          If your target CPU does not have a Floating Point Unit (FPU) or a
          kernel FPU emulator, but you still wish to support floating point
index 99b3e27ceb80d126f7225634eab19297d27aeb4e..822de1c136f9f5848a79b27136e5f992b5adb25a 100644 (file)
@@ -11,14 +11,6 @@ TARGET_OPTIMIZATION:=$(strip $(subst ",, $(BR2_TARGET_OPTIMIZATION)))
 EXTRA_GCC_CONFIG_OPTIONS:=$(strip $(subst ",, $(BR2_EXTRA_GCC_CONFIG_OPTIONS)))
 #"))
 
-# AVR32 GCC configuration
-ifeq ($(strip $(BR2_avr32)),y)
-EXTRA_GCC_CONFIG_OPTIONS+=--disable-libmudflap
-EXTRA_GCC_CONFIG_OPTIONS+=--disable-libssp
-EXTRA_GCC_CONFIG_OPTIONS+=--with-build-time-tools=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin \
-#EXTRA_GCC_CONFIG_OPTIONS+=--with-as=$(TARGET_CROSS)as
-endif
-
 ifeq ($(strip $(subst ",, $(BR2_GCC_IS_SNAP))),y)
 #"))
 GCC_SNAP_DATE:=$(strip $(subst ",, $(BR2_GCC_SNAP_DATE)))
@@ -71,6 +63,15 @@ GCC_WITH_ABI:=--with-abi=$(BR2_GCC_TARGET_ABI)
 endif
 endif
 
+# AVR32 GCC configuration
+ifeq ($(strip $(BR2_avr32)),y)
+EXTRA_GCC_CONFIG_OPTIONS+=--disable-libmudflap
+SOFT_FLOAT_CONFIG_OPTION:=
+EXTRA_GCC_CONFIG_OPTIONS+=--disable-libssp
+EXTRA_GCC_CONFIG_OPTIONS+=--with-build-time-tools=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin \
+#EXTRA_GCC_CONFIG_OPTIONS+=--with-as=$(TARGET_CROSS)as
+endif
+
 TARGET_GCC_FLAGS= CFLAGS_FOR_TARGET="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
        CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
        CFLAGS="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \