- put libstdc++.so into the correct place (usr/lib) and make sure that the dir exists
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 21 Aug 2007 10:28:43 +0000 (10:28 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 21 Aug 2007 10:28:43 +0000 (10:28 -0000)
toolchain/gcc/gcc-uclibc-3.x.mk
toolchain/gcc/gcc-uclibc-4.x.mk

index 798ba25b9226f5ad7b053f6675007da83bc156ad..48f6ace69f2c1a0645eaa85eb638659d141645f1 100644 (file)
@@ -309,6 +309,7 @@ endif
        #
        # Ok... that's enough of that.
        #
+       -mkdir -p $(TARGET_DIR)/usr/lib $(TARGET_DIR)/usr/sbin
        touch $@
 
 $(GCC_BUILD_DIR2)/.libs_installed: $(GCC_BUILD_DIR2)/.installed
index 0001de836be22ea5865098c433259926506db412..48446a4b09c079386028a0cb818a731a7dba6bb2 100644 (file)
@@ -333,6 +333,7 @@ endif
        #
        # Ok... that's enough of that.
        #
+       -mkdir -p $(TARGET_DIR)/usr/lib $(TARGET_DIR)/usr/sbin
        touch $@
 
 $(GCC_BUILD_DIR2)/.libs_installed: $(GCC_BUILD_DIR2)/.installed
@@ -342,7 +343,7 @@ ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
        -cp -dpf $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib/libgcc_s* $(TARGET_DIR)/lib/
 endif
 ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
-       -cp -dpf $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib/libstdc++.so* $(TARGET_DIR)/lib/
+       -cp -dpf $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib/libstdc++.so* $(TARGET_DIR)/usr/lib/
 endif
 ifeq ($(BR2_INSTALL_LIBGCJ),y)
        -cp -dpf $(STAGING_DIR)/lib/libgcj.so* $(TARGET_DIR)/lib/