projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
06aa683
)
vim: ensure configure doesn't fail if X11 packages are enabled
author
Peter Korsgaard
<jacmet@sunsite.dk>
Sat, 1 Jan 2011 20:53:34 +0000
(21:53 +0100)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Sat, 1 Jan 2011 20:53:34 +0000
(21:53 +0100)
When X11 is detected, vim's configure does a AC_TRY_RUN to detect wchar_t
size, so preset it.
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/vim/vim.mk
patch
|
blob
|
history
diff --git
a/package/vim/vim.mk
b/package/vim/vim.mk
index e94bb1e3e7e0fb73d90eb65f979885d77ae76109..917d1d47c89782dc198c39c0b8a15d6f5ac10574 100644
(file)
--- a/
package/vim/vim.mk
+++ b/
package/vim/vim.mk
@@
-17,7
+17,9
@@
VIM_CONF_ENV = vim_cv_toupper_broken=no \
vim_cv_getcwd_broken=no \
vim_cv_stat_ignores_slash=yes \
vim_cv_memmove_handles_overlap=yes \
- ac_cv_sizeof_int=4
+ ac_cv_sizeof_int=4 \
+ ac_cv_small_wchar_t=no
+
VIM_CONF_OPT = --with-tlib=ncurses
define VIM_INSTALL_TARGET_CMDS