packages: rename FOO_GETTEXTIZE_OPT into FOO_GETTEXTIZE_OPTS
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Sat, 27 Sep 2014 19:32:46 +0000 (21:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 4 Oct 2014 16:54:42 +0000 (18:54 +0200)
To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS,
make the same change for FOO_GETTEXTIZE_OPT.

Sed command used:
   find * -type f | xargs sed -i 's#_GETTEXTIZE_OPT\>#&S#g'

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
docs/manual/adding-packages-autotools.txt
package/pkg-autotools.mk

index 1a59de3d6e266f05c524c8104fae58d2f805cd74..ece6c49563fc4ca8b6e81e9a537be484b0f269f9 100644 (file)
@@ -136,7 +136,7 @@ cases, typical packages will therefore only use a few of them.
   'gettextize'.) Only valid when +LIBFOO_AUTORECONF=YES+. Valid
   values are +YES+ and +NO+. The default is +NO+.
 
-* +LIBFOO_GETTEXTIZE_OPT+, to specify additional options passed to
+* +LIBFOO_GETTEXTIZE_OPTS+, to specify additional options passed to
   the 'gettextize' program, if +LIBFOO_GETTEXTIZE=YES+. You may
   use that if, for example, the +.po+ files are not located in the
   standard place (i.e. in +po/+ at the root of the package.) By
index 3bfa140634d3ce64537252a808fc8970b763d064..2c93dd96c3482b827b4ab93f70ab5dbcce51c1d4 100644 (file)
@@ -96,7 +96,7 @@ ifndef $(2)_GETTEXTIZE
 endif
 
 ifeq ($(4),host)
- $(2)_GETTEXTIZE_OPT ?= $$($(3)_GETTEXTIZE_OPT)
+ $(2)_GETTEXTIZE_OPTS ?= $$($(3)_GETTEXTIZE_OPTS)
 endif
 
 ifeq ($(4),host)
@@ -220,7 +220,7 @@ endif
 #
 define GETTEXTIZE_HOOK
        @$$(call MESSAGE,"Gettextizing")
-       $(Q)cd $$($$(PKG)_SRCDIR) && $$(GETTEXTIZE) $$($$(PKG)_GETTEXTIZE_OPT)
+       $(Q)cd $$($$(PKG)_SRCDIR) && $$(GETTEXTIZE) $$($$(PKG)_GETTEXTIZE_OPTS)
 endef
 
 #