package/polkit: add linux-pam as a dependency if linux-pam is selected
authorAdam Duskett <Aduskett@gmail.com>
Sun, 15 Mar 2020 20:56:10 +0000 (13:56 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 15 Mar 2020 21:11:44 +0000 (22:11 +0100)
Without linux-pam built first, polkit will throw a configuration error:
configure: error: Could not find pam/pam-devel, please install the needed packages.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/polkit/polkit.mk

index bc9e3580ab4e0c72ab3b53708fac1ddb204d4972..efd788a05c2d00bb0586b6427fef46dd92c70464 100644 (file)
@@ -24,6 +24,7 @@ POLKIT_CONF_OPTS = \
        --disable-libsystemd-login
 
 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
+POLKIT_DEPENDENCIES += linux-pam
 POLKIT_CONF_OPTS += --with-authfw=pam
 else
 POLKIT_CONF_OPTS += --with-authfw=shadow