Makefile: savedefconfig: save in O= directory for out-of-tree builds
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 2 Feb 2011 14:33:10 +0000 (15:33 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 2 Feb 2011 14:54:50 +0000 (15:54 +0100)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 3ecc597b58b7b95901898593f5ce5150a340e475..956374082614b876dcea822db1dbed21b0aa20b5 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -603,7 +603,7 @@ defconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
 
 savedefconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
        @mkdir -p $(BUILD_DIR)/buildroot-config
-       @$(COMMON_CONFIG_ENV) $< --savedefconfig=$(TOPDIR)/defconfig $(CONFIG_CONFIG_IN)
+       @$(COMMON_CONFIG_ENV) $< --savedefconfig=$(CONFIG_DIR)/defconfig $(CONFIG_CONFIG_IN)
 
 # check if download URLs are outdated
 source-check: allyesconfig