package/qwt: partially convert to qmake infrastructure
authorAndreas Naumann <anaumann@ultratronik.de>
Mon, 17 Feb 2020 21:23:27 +0000 (22:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 11 Mar 2020 21:10:55 +0000 (22:10 +0100)
Use the qmake infrastructure for its generic configure and build steps
but keep the manipulation of qwtconfig.pri as a PRE_CONFIGURE_HOOK as
well as the custom install steps.

Signed-off-by: Andreas Naumann <anaumann@ultratronik.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qwt/qwt.mk

index a82c786cb15bbc869d777d22fc33c4ed67a13c80..f09304d0e4e76e686fef39711604e278af7dd70a 100644 (file)
@@ -8,7 +8,6 @@ QWT_VERSION = 6.1.4
 QWT_SOURCE = qwt-$(QWT_VERSION).tar.bz2
 QWT_SITE = http://downloads.sourceforge.net/project/qwt/qwt/$(QWT_VERSION)
 QWT_INSTALL_STAGING = YES
-QWT_DEPENDENCIES = qt5base
 
 QWT_LICENSE = LGPL-2.1 with exceptions
 QWT_LICENSE_FILES = COPYING
@@ -42,14 +41,11 @@ else
 QWT_CONFIG += -e 's/^.*QWT_CONFIG.*QwtDll.*$$/QWT_CONFIG += QwtDll/'
 endif
 
-define QWT_CONFIGURE_CMDS
+define QWT_TWEAK_QWTCONFIG_PRI
        $(SED) $(QWT_CONFIG) $(@D)/qwtconfig.pri
-       (cd $(@D); $(TARGET_MAKE_ENV) $(QT5_QMAKE))
 endef
 
-define QWT_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
-endef
+QWT_PRE_CONFIGURE_HOOKS += QWT_TWEAK_QWTCONFIG_PRI
 
 # After installation, we fixup the INSTALL_PREFIX in qwtconfig.pri so
 # that when building with qmake, -L$(STAGING_DIR)/usr/lib is used and
@@ -65,4 +61,4 @@ define QWT_INSTALL_TARGET_CMDS
        rm -Rf $(TARGET_DIR)/usr/mkspecs
 endef
 
-$(eval $(generic-package))
+$(eval $(qmake-package))