package/vlc: add optional support for xcb-util-keysyms
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 28 Feb 2016 20:18:27 +0000 (21:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 5 Mar 2016 14:02:30 +0000 (15:02 +0100)
When xcb-util-keysyms was compiled before, vlc will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/lib/vlc/plugins/control/libxcb_hotkeys_plugin.so | grep NEEDED | sort
[...]
 0x0000000000000001 (NEEDED)             Shared library: [libxcb-keysyms.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libxcb.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libXdmcp.so.6]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vlc/vlc.mk

index bf1ec450584830466593761a1c35275afcd0178f..b67bd3555181bf496bfb08cc0de71a9402f989f9 100644 (file)
@@ -393,6 +393,13 @@ else
 VLC_CONF_OPTS += --disable-udev
 endif
 
+ifeq ($(BR2_PACKAGE_XCB_UTIL_KEYSYMS),y)
+VLC_CONF_OPTS += --enable-xcb
+VLC_DEPENDENCIES += xcb-util-keysyms
+else
+VLC_CONF_OPTS += --disable-xcb
+endif
+
 ifeq ($(BR2_PACKAGE_XLIB_LIBX11),y)
 VLC_CONF_OPTS += --with-x
 VLC_DEPENDENCIES += xlib_libX11