madplay: fixes build when toolchain has locale support
authorJulien Boibessot <julien.boibessot@armadeus.com>
Mon, 10 Feb 2014 10:17:48 +0000 (11:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 10 Feb 2014 15:07:12 +0000 (16:07 +0100)
Otherwise build fails in intl/relocatable.c with:
./relocatable.c: In function 'libintl_relocate':
./relocatable.c:402:40: error: 'INSTALLPREFIX' undeclared (first use in this function)
./relocatable.c:402:40: note: each undeclared identifier is reported only once for each function it appears in

[Peter: drop redundant 'else' part]
Signed-off-by: Julien Boibessot <julien.boibessot@armadeus.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/madplay/Config.in
package/madplay/madplay.mk

index 3baeaa06314a102aa612b0bbdf45129be2c11c11..d83fac6d1f30a19582a61be23cc669429207da92 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_MADPLAY
        bool "madplay"
        select BR2_PACKAGE_LIBMAD
        select BR2_PACKAGE_LIBID3TAG
+       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          Command-line front-end to libmad, a high-quality MPEG audio decoder.
          It currently supports MPEG-1 and the MPEG-2 extension to lower
index 35aa65166a543a080d107e8319fecf9970c1283f..3f68dffb81712c5f2a4852c6a1fa44028eb403ea 100644 (file)
@@ -9,7 +9,7 @@ MADPLAY_SITE = http://downloads.sourceforge.net/project/mad/madplay/$(MADPLAY_VE
 MADPLAY_LICENSE = GPLv2+
 MADPLAY_LICENSE_FILES = COPYING COPYRIGHT
 MADPLAY_LIBTOOL_PATCH = NO
-MADPLAY_DEPENDENCIES = libmad libid3tag
+MADPLAY_DEPENDENCIES = libmad libid3tag $(if $(BR2_PACKAGE_GETTEXT),gettext)
 
 # Check if ALSA is built, then we should configure after alsa-lib so
 # ./configure can find alsa-lib.