time: needs mmu
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 17 Sep 2013 12:12:30 +0000 (09:12 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 17 Sep 2013 13:26:52 +0000 (15:26 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/time/Config.in
package/time/time.mk

index 634d41a4981649dacd8a9281b8cc4570eef8ce3b..0ec3be351a1eaf8aaaad85edf46175569abdc3f8 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_TIME
        bool "time"
+       depends on BR2_USE_MMU # fork()
        help
          The GNU time utility.
 
index b7ee40c6ad61fe565c4c8b0ee310b0c20a4c6f69..56f28ff484c0f1f5af0ddde6412d4932f1f36a20 100644 (file)
@@ -7,11 +7,13 @@
 TIME_VERSION = 1.7
 TIME_SITE = $(BR2_GNU_MIRROR)/time
 TIME_CONF_ENV = ac_cv_func_wait3=yes
+TIME_LICENSE = GPLv2+
+TIME_LICENSE_FILES = COPYING
 
 # time uses an old version of automake that does not support
 # installing in DESTDIR.
 define TIME_INSTALL_TARGET_CMDS
-       install -D -m 755  $(@D)/time $(TARGET_DIR)/usr/bin/time
+       $(INSTALL) -D -m 755  $(@D)/time $(TARGET_DIR)/usr/bin/time
 endef
 
 $(eval $(autotools-package))