Makefile: cleanup *conf targets
authorPeter Korsgaard <jacmet@sunsite.dk>
Sat, 5 Jun 2010 18:54:43 +0000 (20:54 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 5 Jun 2010 19:14:59 +0000 (21:14 +0200)
The make targets for the kconfig conf/mconf/qconf are almost identical,
so us a single rule for it.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index e36b47541ae6943f97eaccd03b3262b36572224c..a75ca3e5f23f58fc9b15f0aabc9b0c977d2a665a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -469,23 +469,9 @@ all: menuconfig
 HOSTCFLAGS=$(CFLAGS_FOR_BUILD)
 export HOSTCFLAGS
 
-$(CONFIG)/conf:
-       @mkdir -p $(CONFIG)/buildroot-config
-       $(MAKE) CC="$(HOSTCC)" -C $(CONFIG) conf
-       -@if [ ! -f .config ]; then \
-               cp $(CONFIG_DEFCONFIG) .config; \
-       fi
-
-$(CONFIG)/mconf:
-       @mkdir -p $(CONFIG)/buildroot-config
-       $(MAKE) CC="$(HOSTCC)" -C $(CONFIG) mconf
-       -@if [ ! -f .config ]; then \
-               cp $(CONFIG_DEFCONFIG) .config; \
-       fi
-
-$(CONFIG)/qconf:
-       @mkdir -p $(CONFIG)/buildroot-config
-       $(MAKE) CC="$(HOSTCC)" -C $(CONFIG) qconf
+$(CONFIG)/%onf:
+       mkdir -p $(CONFIG)/buildroot-config
+       $(MAKE) CC="$(HOSTCC)" -C $(CONFIG) $(notdir $@)
        -@if [ ! -f .config ]; then \
                cp $(CONFIG_DEFCONFIG) .config; \
        fi
@@ -513,7 +499,7 @@ config: $(CONFIG)/conf
                $(CONFIG)/conf $(CONFIG_CONFIG_IN)
 
 oldconfig: $(CONFIG)/conf
-       @mkdir -p $(CONFIG)/buildroot-config
+       mkdir -p $(CONFIG)/buildroot-config
        @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
                KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
                $(CONFIG)/conf -o $(CONFIG_CONFIG_IN)