support/scripts/br2-external: declare missing local variables
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 29 Jul 2019 20:19:51 +0000 (22:19 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 3 Aug 2019 17:58:17 +0000 (19:58 +0200)
Commit b14b02698 (core/br2-external: restore compatibility with old
distros) switched to using 'eval' to emulate associative arrays, for
those distros too old to have bash-4+.

In so doing, it forgot to declare the new local variables in the
respective helper functions.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Vadim Kochan <vadim4j@gmail.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Ricardo Martincoski <ricardo.martincoski@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
support/scripts/br2-external

index 00cb57d1eda3f972d07429804bf792dd5a659568..5097d617f3b0a2ef5a8f094eb845e65f658a036a 100755 (executable)
@@ -119,7 +119,7 @@ do_validate_one() {
 # Generate the .mk snippet that defines makefile variables
 # for the br2-external tree
 do_mk() {
-    local br2_name br2_ext
+    local br2_name br2_desc br2_ext
 
     printf '#\n# Automatically generated file; DO NOT EDIT.\n#\n'
     printf '\n'
@@ -155,7 +155,7 @@ do_mk() {
 
 # Generate the kconfig snippet for the br2-external tree.
 do_kconfig() {
-    local br2_name br2_ext
+    local br2_name br2_desc br2_ext
 
     printf '#\n# Automatically generated file; DO NOT EDIT.\n#\n'
     printf '\n'