package/mesa3d: disable libva support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 29 Jul 2015 19:42:54 +0000 (21:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 29 Jul 2015 20:48:53 +0000 (22:48 +0200)
Informations about the circular dependency can be found here:
http://linuxfromscratch.org/blfs/view/systemd/multimedia/libva.html

Fixes
http://autobuild.buildroot.net/results/b51/b516676ca0e695b3dbc3c33622d527b89a227932/
http://autobuild.buildroot.net/results/035/03588be2fbd71bfc68619297dace52a909ffe261/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/mesa3d.mk

index e5afed2739dc01c95916a645b222902c05bf54f7..82b1001539de4bd96b5e63044ba684bc10fe2856 100644 (file)
@@ -121,6 +121,10 @@ endif
 #     remove dri.pc and gl.pc in this case (MESA3D_REMOVE_OPENGL_PC)
 MESA3D_CONF_OPTS += --enable-opengl
 
+# libva and mesa3d have a circular dependency
+# we do not need libva support in mesa3d, therefore disable this option
+MESA3D_CONF_OPTS += --disable-va
+
 ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_EGL),y)
 MESA3D_PROVIDES += libegl
 MESA3D_EGL_PLATFORMS = drm