xmlstarlet: use $() to reference make variables instead of ${}
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 16 Nov 2016 21:11:49 +0000 (22:11 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 16 Nov 2016 21:11:49 +0000 (22:11 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xmlstarlet/xmlstarlet.mk

index 7039d7738f674c63abaf7d97b2e7a68c1f3b556f..98efd077308694e174ddbde4cf27d8f31ec09a9e 100644 (file)
@@ -15,9 +15,9 @@ XMLSTARLET_DEPENDENCIES += libxml2 libxslt \
        $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 
 XMLSTARLET_CONF_OPTS += \
-       --with-libxml-prefix=${STAGING_DIR}/usr \
-       --with-libxslt-prefix=${STAGING_DIR}/usr \
-       --with-libiconv-prefix=${STAGING_DIR}/usr
+       --with-libxml-prefix=$(STAGING_DIR)/usr \
+       --with-libxslt-prefix=$(STAGING_DIR)/usr \
+       --with-libiconv-prefix=$(STAGING_DIR)/usr
 
 ifeq ($(BR2_STATIC_LIBS),y)
 XMLSTARLET_CONF_OPTS += --enable-static-libs