weston: add support for XWayland
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 26 May 2016 19:44:58 +0000 (16:44 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 27 May 2016 21:06:10 +0000 (23:06 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/weston/Config.in
package/weston/weston.mk

index 44f954abe06b045bca7b8ae41799d0514a3a8f47..0812279cf7e65520a67a94ba5a57924768662be5 100644 (file)
@@ -92,4 +92,16 @@ config BR2_PACKAGE_WESTON_X11
 comment "X11 compositor needs X.org enabled"
        depends on !BR2_PACKAGE_XORG7
 
+config BR2_PACKAGE_WESTON_XWAYLAND
+       bool "XWayland support"
+       depends on BR2_PACKAGE_XORG7
+       depends on BR2_PACKAGE_LIBEPOXY
+       select BR2_PACKAGE_CAIRO
+       select BR2_PACKAGE_LIBXCB
+       select BR2_PACKAGE_XLIB_LIBX11
+       select BR2_PACKAGE_XLIB_LIBXCURSOR
+
+comment "XWayland support needs libepoxy and X.org enabled"
+       depends on !BR2_PACKAGE_XORG7 || !BR2_PACKAGE_LIBEPOXY
+
 endif
index 3a0189f1ae4f29565e3410e3d39ff763f00e7dcf..38a0d37020595573a7b2c086f6cff2f5e5a42de3 100644 (file)
@@ -18,7 +18,6 @@ WESTON_DEPENDENCIES = host-pkgconf wayland wayland-protocols \
 
 WESTON_CONF_OPTS = \
        --with-dtddir=$(STAGING_DIR)/usr/share/wayland \
-       --disable-xwayland \
        --disable-wayland-compositor \
        --disable-headless-compositor \
        --disable-colord \
@@ -111,6 +110,13 @@ else
 WESTON_CONF_OPTS += --disable-x11-compositor
 endif
 
+ifeq ($(BR2_PACKAGE_WESTON_XWAYLAND),y)
+WESTON_CONF_OPTS += --enable-xwayland
+WESTON_DEPENDENCIES += cairo libepoxy libxcb xlib_libX11 xlib_libXcursor
+else
+WESTON_CONF_OPTS += --disable-xwayland
+endif
+
 ifeq ($(BR2_PACKAGE_LIBVA),y)
 WESTON_CONF_OPTS += --enable-vaapi-recorder
 WESTON_DEPENDENIES += libva