purge-locales: skip /usr/man and /usr/share/man
authorArnout Vandecappelle <arnout@mind.be>
Mon, 13 Jul 2015 21:00:34 +0000 (23:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 13 Jul 2015 21:25:58 +0000 (23:25 +0200)
These directories are going to be removed anyway, so no point purging
their locales.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 546bcd34bf0a51eed532e72a25845e3de77d57c5..02a103244290c1411a7156d75cb89ab61d811a95 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -544,7 +544,7 @@ define PURGE_LOCALES
        rm -f $(LOCALE_WHITELIST)
        for i in $(LOCALE_NOPURGE) locale-archive; do echo $$i >> $(LOCALE_WHITELIST); done
 
-       for dir in $(wildcard $(addprefix $(TARGET_DIR),/usr/share/locale /usr/share/X11/locale /usr/man /usr/share/man /usr/lib/locale)); \
+       for dir in $(wildcard $(addprefix $(TARGET_DIR),/usr/share/locale /usr/share/X11/locale /usr/lib/locale)); \
        do \
                for lang in $$(cd $$dir; ls .|grep -v man); \
                do \