package/dvb-apps: bump revision
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 28 Mar 2014 00:00:24 +0000 (01:00 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Mar 2014 17:30:37 +0000 (18:30 +0100)
In this new revision, there is no longer transponders data, so dvb-apps
now only installs the dvb-apps utilities.

Packages that needs the transponders data have now all been switched to
use dtv-scan-tables instead, so we don't need a legacy option for the
transponders data.

However, we add a legacy option for the utilities option, just to inform
the user of the new behaviour.

Sadly, a user that had dvb-apps selected just to get the transponders
data will now get the full dvb-apps package installed. There's nothing
we can really do about this.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/dvb-apps/Config.in
package/dvb-apps/dvb-apps.mk

index afcd3b1b5456b8c617a1f5ee93b1656052e78109..17ead9b9de917129542fc2c40cfe6e7a3efdc942 100644 (file)
@@ -101,6 +101,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2014.05"
 
+config BR2_PACKAGE_DVB_APPS_UTILS
+       bool "dvb-apps utilities now built by default"
+       select BR2_LEGACY
+       help
+         The dvb-apps utilities are now always built when the dvb-apps
+         package is selected.
+
 config BR2_KERNEL_HEADERS_SNAP
        bool "Local Linux snapshot support removed"
        select BR2_LEGACY
index 76b33aabb717110caf69c5a45f0891c8391f0c80..3f8fdb657eaec5076591e2b16c6a5a6c3a0f1e5d 100644 (file)
@@ -1,25 +1,15 @@
 config BR2_PACKAGE_DVB_APPS
-       bool "dvb-apps (transponders data)"
-       select BR2_PACKAGE_DTV_SCAN_TABLES
-       help
-         Install the DVB-C, DVB-S, DVB-T and ATSC transponders data.
-
-         http://linuxtv.org/projects.php
-         http://linuxtv.org/hg/dvb-apps
-
-if BR2_PACKAGE_DVB_APPS
-
-comment "dvb-apps utils needs a toolchain w/ largefile, threads, headers >= 3.3"
-       depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_3
-
-config BR2_PACKAGE_DVB_APPS_UTILS
-       bool "dvb-apps utilities"
+       bool "dvb-apps"
        depends on BR2_LARGEFILE
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_3
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        help
-         A small number of DVB test and utility programs,
+         Install a small number of DVB test and utility programs,
          including szap and dvbscan.
 
-endif
+         http://linuxtv.org/projects.php
+         http://linuxtv.org/hg/dvb-apps
+
+comment "dvb-apps utils needs a toolchain w/ largefile, threads, headers >= 3.3"
+       depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_3
index 5f576e079fb89046ee0fa62bf1ab768db65d4420..c5e19545673928a60dbafa798067ed2f67cd975a 100644 (file)
@@ -4,15 +4,9 @@
 #
 ################################################################################
 
-DVB_APPS_VERSION        = be76da69f250
+DVB_APPS_VERSION        = 3d43b280298c39a67d1d889e01e173f52c12da35
 DVB_APPS_SITE           = http://linuxtv.org/hg/dvb-apps
 DVB_APPS_SITE_METHOD    = hg
-
-DVB_APPS_DEPENDENCIES   = dtv-scan-tables
-
-ifeq ($(BR2_PACKAGE_DVB_APPS_UTILS),y)
-# Utilitiess are selected, build and install everything
-
 DVB_APPS_LICENSE        = GPLv2 GPLv2+ LGPLv2.1+
 DVB_APPS_LICENSE_FILES  = COPYING COPYING.LGPL
 
@@ -38,9 +32,4 @@ define DVB_APPS_INSTALL_TARGET_CMDS
        $(MAKE) -C $(@D) V=1 DESTDIR=$(TARGET_DIR) install
 endef
 
-else
-# We do not really install anything, so there's no license
-DVB_APPS_LICENSE        = none
-endif
-
 $(eval $(generic-package))