Add in a GNU_HOST_NAME
authorEric Andersen <andersen@codepoet.org>
Tue, 4 Mar 2003 07:56:11 +0000 (07:56 -0000)
committerEric Andersen <andersen@codepoet.org>
Tue, 4 Mar 2003 07:56:11 +0000 (07:56 -0000)
Makefile

index 9f0f84d816ee393b735507d41889a1241afa4ef3..ae8561ec79cf3e1db7ebc13f60558d6b5d579a51 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -155,6 +155,18 @@ STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
 IMAGE:=$(BASE_DIR)/root_fs
 GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux
 KERNEL_CROSS=$(STAGING_DIR)/bin/$(ARCH)-uclibc-
+HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
+       -e 's/sparc.*/sparc/' \
+       -e 's/arm.*/arm/g' \
+       -e 's/m68k.*/m68k/' \
+       -e 's/ppc/powerpc/g' \
+       -e 's/v850.*/v850/g' \
+       -e 's/sh[234]/sh/' \
+       -e 's/mips-.*/mips/' \
+       -e 's/mipsel-.*/mipsel/' \
+       -e 's/cris.*/cris/' \
+       )
+GNU_HOST_NAME:=$(HOST_ARCH)-pc-linux-gnu
 
 all:   world