midori: bump to 0.2.9 and make it build with directfb
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 5 Nov 2010 20:14:13 +0000 (17:14 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 19 Nov 2010 06:24:15 +0000 (07:24 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/midori/midori.mk

diff --git a/CHANGES b/CHANGES
index 748738eee9a476994f04431021265625d2d5942b..0e2732415f08e69dae4011d0a13b0542e68c0667 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -2,7 +2,7 @@
 
        Fixes all over the tree.
 
-       Updated/fixed packages: libglib2, module-init-tools,
+       Updated/fixed packages: libglib2, midori, module-init-tools,
        mtd-utils, openssh, qt, sqlite, webkit
 
        Issues resolved (http://bugs.uclibc.org):
index ffee596fbfe9cdee8c922c33af24a3a5016125a1..af227d4eb174d569a42b762b186345487ae72e44 100644 (file)
@@ -4,19 +4,26 @@
 #
 #############################################################
 
-MIDORI_VERSION = 0.2.6
+MIDORI_VERSION = 0.2.9
 MIDORI_SOURCE = midori-$(MIDORI_VERSION).tar.bz2
 MIDORI_SITE = http://archive.xfce.org/src/apps/midori/0.2/
-MIDORI_INSTALL_STAGING = NO
 MIDORI_INSTALL_TARGET = YES
 
 MIDORI_DEPENDENCIES = host-pkg-config host-intltool webkit libsexy libgtk2
 
+ifneq ($(BR2_PACKAGE_XORG7),y)
+define MIDORI_WITHOUT_X11
+       $(SED) "s/check_pkg ('x11')/#check_pkg ('x11')/" $(@D)/wscript
+endef
+endif
+
 define MIDORI_CONFIGURE_CMDS
-       (cd $(@D); \
-               $(TARGET_CONFIGURE_OPTS)        \
-               ./waf configure                 \
-               --prefix=/usr                   \
+       $(MIDORI_WITHOUT_X11)
+       (cd $(@D); \
+               $(TARGET_CONFIGURE_OPTS)        \
+               ./waf configure                 \
+               --prefix=/usr                   \
+               --disable-vala                  \
        )
 endef