fs/skeleton: allow rootfs not to be remounted read-write
authorLuca Ceresoli <luca@lucaceresoli.net>
Sun, 3 Jul 2011 10:56:03 +0000 (12:56 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 10 Jul 2011 20:44:24 +0000 (22:44 +0200)
[Peter: prefix option with TARGET_GENERIC_]
Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
fs/skeleton/etc/inittab
package/sysvinit/inittab
target/generic/Config.in
target/generic/Makefile.in

index 4f3bb965d21b2116192abdca683960202b94ad30..ac410d6e4e62857610e296551b2c4e2a72ec424a 100644 (file)
@@ -15,7 +15,7 @@
 
 # Startup the system
 null::sysinit:/bin/mount -t proc proc /proc
-null::sysinit:/bin/mount -o remount,rw /
+null::sysinit:/bin/mount -o remount,rw / # REMOUNT_ROOTFS_RW
 null::sysinit:/bin/mkdir -p /dev/pts
 null::sysinit:/bin/mkdir -p /dev/shm
 null::sysinit:/bin/mount -a
index a4bcf82d33ccf788976bb6fd9ee9b8685ac8330d..afa0dc35c97983ff1495c94b3bc0f258aa4aed9d 100644 (file)
@@ -5,7 +5,7 @@
 id:1:initdefault:
 
 proc::sysinit:/bin/mount -t proc proc /proc
-rwmo::sysinit:/bin/mount -o remount,rw /
+rwmo::sysinit:/bin/mount -o remount,rw / # REMOUNT_ROOTFS_RW
 dpts::sysinit:/bin/mkdir -p /dev/pts
 moun::sysinit:/bin/mount -a
 host::sysinit:/bin/hostname -F /etc/hostname
index 4969fcdc443b2a5b59387e263fe7c484a8c945f7..7961beccc840ace8cb02eddd82e334e6a6fdb49d 100644 (file)
@@ -109,6 +109,17 @@ config BR2_TARGET_GENERIC_GETTY_BAUDRATE
        default "57600"         if BR2_TARGET_GENERIC_GETTY_BAUDRATE_57600
        default "115200"        if BR2_TARGET_GENERIC_GETTY_BAUDRATE_115200
 
+config BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW
+       bool "remount root filesystem read-write during boot"
+       default y
+       help
+         The root filesystem is typically mounted read-only at boot.
+         By default, buildroot remounts it in read-write mode early during the
+         boot process.
+         Say no here if you would rather like your root filesystem to remain
+         read-only.
+         If unsure, say Y.
+
 endif # BR2_ROOTFS_SKELETON_DEFAULT
 
 config BR2_ROOTFS_POST_BUILD_SCRIPT
index ce07ecfd0fcb4dd27c5488c520c59540408464c4..4185202b730c0f52f880a67cc08df2961eceabfa 100644 (file)
@@ -23,6 +23,14 @@ target-generic-getty-sysvinit:
        $(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(shell echo $(TARGET_GENERIC_GETTY) | tail -c+4)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
                $(TARGET_DIR)/etc/inittab
 
+# Find commented line, if any, and remove leading '#'s
+target-generic-do-remount-rw:
+       $(SED) '/^#.*# REMOUNT_ROOTFS_RW$$/s~^#\+~~' $(TARGET_DIR)/etc/inittab
+
+# Find uncommented line, if any, and add a leading '#'
+target-generic-dont-remount-rw:
+       $(SED) '/^[^#].*# REMOUNT_ROOTFS_RW$$/s~^~#~' $(TARGET_DIR)/etc/inittab
+
 ifneq ($(TARGET_GENERIC_HOSTNAME),)
 TARGETS += target-generic-hostname
 endif
@@ -37,4 +45,9 @@ TARGETS += target-generic-getty-sysvinit
 else
 TARGETS += target-generic-getty-busybox
 endif
+ifeq ($(BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW),y)
+TARGETS += target-generic-do-remount-rw
+else
+TARGETS += target-generic-dont-remount-rw
+endif
 endif