so just disable it.
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
+[Gustavo: update for 1.3.5]
-diff -Nura graphite2-1.3.3.orig/src/CMakeLists.txt graphite2-1.3.3/src/CMakeLists.txt
---- graphite2-1.3.3.orig/src/CMakeLists.txt 2015-09-24 10:06:28.877851596 -0300
-+++ graphite2-1.3.3/src/CMakeLists.txt 2015-09-24 10:06:48.201519767 -0300
+diff -Nura graphite2-1.3.5.orig/src/CMakeLists.txt graphite2-1.3.5/src/CMakeLists.txt
+--- graphite2-1.3.5.orig/src/CMakeLists.txt 2016-02-15 11:46:45.941906112 -0300
++++ graphite2-1.3.5/src/CMakeLists.txt 2016-02-15 11:46:54.237194222 -0300
@@ -111,9 +111,6 @@
COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wendif-labels -Wshadow -Wctor-dtor-privacy -Wnon-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden -fno-stack-protector"
LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
- if (CMAKE_COMPILER_IS_GNUCXX)
- add_definitions(-Wdouble-promotion)
- endif (CMAKE_COMPILER_IS_GNUCXX)
- if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
- target_link_libraries(graphite2 kernel32 msvcr90 mingw32 gcc user32)
- else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
+ message(STATUS "Compiler ID is: ${CMAKE_CXX_COMPILER_ID}")
+ if (${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang")
+ add_definitions(-Wimplicit-fallthrough)
# From http://sourceforge.net/projects/silgraphite/files/graphite2
-md5 7cda6fc6bc197b216777b15ce52c38a8 graphite2-1.3.3.tgz
-sha1 54b04c283bab4695de63ae2dd6cff392dd49d7f0 graphite2-1.3.3.tgz
+md5 5b8d22a8bbf031838e31432868c0109c graphite2-1.3.5.tgz
+sha1 044f65d5b4ade3169f5fcd75a25f047c81f5d33e graphite2-1.3.5.tgz
#
################################################################################
-GRAPHITE2_VERSION = 1.3.3
+GRAPHITE2_VERSION = 1.3.5
GRAPHITE2_SOURCE = graphite2-$(GRAPHITE2_VERSION).tgz
GRAPHITE2_SITE = http://downloads.sourceforge.net/project/silgraphite/graphite2
GRAPHITE2_INSTALL_STAGING = YES