python-scapy3k: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Wed, 22 Jun 2016 13:49:04 +0000 (15:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Jul 2016 21:37:49 +0000 (23:37 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-scapy3k/Config.in [new file with mode: 0644]
package/python-scapy3k/python-scapy3k.hash [new file with mode: 0644]
package/python-scapy3k/python-scapy3k.mk [new file with mode: 0644]

index a6cc258264bd838dad4d181c4e708240c2d121d3..5779d046775d7b3ef0a7c82bbc3e3c421a2e7ff8 100644 (file)
@@ -756,6 +756,7 @@ menu "External python modules"
        source "package/python-requests/Config.in"
        source "package/python-rpi-gpio/Config.in"
        source "package/python-rtslib-fb/Config.in"
+       source "package/python-scapy3k/Config.in"
        source "package/python-sdnotify/Config.in"
        source "package/python-serial/Config.in"
        source "package/python-service-identity/Config.in"
diff --git a/package/python-scapy3k/Config.in b/package/python-scapy3k/Config.in
new file mode 100644 (file)
index 0000000..3e75fcd
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_SCAPY3K
+       bool "python-scapy3k"
+       depends on BR2_PACKAGE_PYTHON3
+       select BR2_PACKAGE_PYTHON3_ZLIB
+       help
+         Network packet and pcap file crafting/sniffing/manipulation
+         security tool (based on scapy) with python3 compatibility.
+
+         https://github.com/phaethon/scapy
diff --git a/package/python-scapy3k/python-scapy3k.hash b/package/python-scapy3k/python-scapy3k.hash
new file mode 100644 (file)
index 0000000..36d5dfe
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256  a4c68ef2f787d82a3aec8640cac8dbab6f5b9e31ae4d89a1877efbb9150a9e25  python-scapy3k-v0.18.tar.gz
diff --git a/package/python-scapy3k/python-scapy3k.mk b/package/python-scapy3k/python-scapy3k.mk
new file mode 100644 (file)
index 0000000..661cb9d
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+#
+# python-scapy3k
+#
+################################################################################
+
+PYTHON_SCAPY3K_VERSION = v0.18
+PYTHON_SCAPY3K_SITE = $(call github,phaethon,scapy,$(PYTHON_SCAPY3K_VERSION))
+PYTHON_SCAPY3K_SETUP_TYPE = distutils
+PYTHON_SCAPY3K_LICENSE = GPLv2+
+
+$(eval $(python-package))