xenomai: Add config for enabling/disabling SMP
authorPawel Sikora <sikor6@gmail.com>
Mon, 10 Apr 2017 17:26:03 +0000 (19:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 12 Apr 2017 20:59:56 +0000 (22:59 +0200)
Add a config option for enabling/disabling SMP
in Xenomai userspace in version 3.x

Enabled by default.

Signed-off-by: Pawel Sikora <sikor6@gmail.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout at mind.be>
Reviewed-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
[Thomas: implement minor tweaks suggested by Thomas DS.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xenomai/Config.in
package/xenomai/xenomai.mk

index 324f5025afaa11a14c9c22059548514e0eab22e7..8acf5794dafd1d0b83536b33af887b331a65a5d5 100644 (file)
@@ -78,6 +78,24 @@ config BR2_PACKAGE_XENOMAI_COBALT
          in the Linux Kernel Extensions menu.
 endchoice
 
+config BR2_PACKAGE_XENOMAI_ENABLE_SMP
+       bool "Enable SMP support"
+       default y
+       help
+         This option enables SMP support in Xenomai userspace.
+
+         If this option is turned on while no SMP support is enabled
+         in the kernel, things will still work. However, if SMP is
+         enabled in the kernel but this option is not turned on,
+         Xenomai applications will complain with:
+
+           feature mismatch: missing="smp/nosmp"
+
+         Please refer to this troubleshooting guide for more
+         information:
+
+         http://xenomai.org/troubleshooting-a-dual-kernel-configuration/#feature_mismatch_missing8221smpnosmp8221
+
 config BR2_PACKAGE_XENOMAI_TESTSUITE
        bool "Install testsuite"
        help
index 73d9617b1ff467abb3c88f004e7abe706e4cdab5..bd147a9ec6c2b04866e1dea93339d62969238a7e 100644 (file)
@@ -29,6 +29,12 @@ else
 XENOMAI_CONF_OPTS += --with-core=cobalt
 endif
 
+ifeq ($(BR2_PACKAGE_XENOMAI_ENABLE_SMP),y)
+XENOMAI_CONF_OPTS += --enable-smp
+else
+XENOMAI_CONF_OPTS += --disable-smp
+endif
+
 define XENOMAI_REMOVE_DEVFILES
        for i in xeno-config xeno-info wrap-link.sh ; do \
                rm -f $(TARGET_DIR)/usr/bin/$$i ; \