package: linux-fusion: use install instead of cp
authorGuido Martínez <guido@vanguardiasur.com.ar>
Mon, 17 Nov 2014 17:19:10 +0000 (14:19 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 18 Nov 2014 22:58:42 +0000 (23:58 +0100)
in order to not depend on the previous permissions of the file

Signed-off-by: Guido Martínez <guido@vanguardiasur.com.ar>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/linux-fusion/linux-fusion.mk

index c5e7976740b6e4a488d8556b0c3cc3e30b59b095..001388c67dc1f38a70e79e4bb58b548944e9cfa6 100644 (file)
@@ -36,8 +36,8 @@ define LINUX_FUSION_INSTALL_TARGET_CMDS
                $(LINUX_FUSION_MAKE_OPTS) \
                INSTALL_MOD_PATH=$(TARGET_DIR) \
                -C $(@D) install
-       mkdir -p $(LINUX_FUSION_ETC_DIR)
-       cp -dpf package/linux-fusion/40-fusion.rules $(LINUX_FUSION_ETC_DIR)
+       $(INSTALL) -D -m 644 package/linux-fusion/40-fusion.rules \
+               $(LINUX_FUSION_ETC_DIR)/40-fusion.rules
 endef
 
 $(eval $(generic-package))