package/hiredis: ssl needs threads
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 5 Sep 2020 11:07:03 +0000 (13:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 5 Sep 2020 21:27:08 +0000 (23:27 +0200)
ssl support which has been added in version 1.0.0 needs threads:

/home/buildroot/autobuild/instance-3/output-1/build/hiredis-1.0.0/ssl.c:42:10: fatal error: pthread.h: No such file or directory
 #include <pthread.h>
          ^~~~~~~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/80ac7500055d167e5ec9a964046de7cca4b4f9f5

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/hiredis/hiredis.mk

index f1f4c49dab6681e6d26b687c9ffb2e81a32edbef..27a26661cffe5951a953b169ae4a6289333c4909 100644 (file)
@@ -12,7 +12,7 @@ HIREDIS_LICENSE_FILES = COPYING
 HIREDIS_INSTALL_STAGING = YES
 HIREDIS_CONF_OPTS = -DDISABLE_TESTS=ON
 
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ifeq ($(BR2_PACKAGE_OPENSSL)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
 HIREDIS_CONF_OPTS += -DENABLE_SSL=ON
 HIREDIS_DEPENDENCIES += openssl
 else