systemd: add compatibility symlink for 'shutdown'
authorAnssi Hannula <anssi.hannula@bitwise.fi>
Fri, 13 Apr 2018 12:18:30 +0000 (15:18 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 15 Apr 2018 19:12:31 +0000 (21:12 +0200)
In addition to the 'halt', 'poweroff', 'reboot' symlinks pointing to
systemctl, add 'shutdown'.

Signed-off-by: Anssi Hannula <anssi.hannula@bitwise.fi>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/systemd.mk

index 76b7e8382fa6f26dca953f32791886f66b7eaf7d..db7fb43636368db9e6c3ebf4d5f066dc32794429 100644 (file)
@@ -340,6 +340,7 @@ define SYSTEMD_INSTALL_INIT_HOOK
        ln -fs ../bin/systemctl $(TARGET_DIR)/sbin/halt
        ln -fs ../bin/systemctl $(TARGET_DIR)/sbin/poweroff
        ln -fs ../bin/systemctl $(TARGET_DIR)/sbin/reboot
+       ln -fs ../bin/systemctl $(TARGET_DIR)/sbin/shutdown
        ln -fs ../../../lib/systemd/system/multi-user.target \
                $(TARGET_DIR)/etc/systemd/system/default.target
 endef