Makefile: exclude BR2_DL_DIR from savedefconfig
authorSven Oliver Moll <buildroot@svol.li>
Wed, 21 Oct 2020 10:34:00 +0000 (12:34 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 21 Oct 2020 19:56:57 +0000 (21:56 +0200)
Running "make savedefconfig" with BR2_DL_DIR set also saves that
variable, which is only useful in local context.

Signed-off-by: Sven Oliver Moll <buildroot@svol.li>
[yann.morin.1998@free.fr: wrap line]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Makefile

index 384bfe3fe933e653620adcfaf27c7c329142e157..d1d19d8f40353f9093192156fb5f34246c10ef71 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1027,7 +1027,9 @@ savedefconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
        @$(COMMON_CONFIG_ENV) $< \
                --savedefconfig=$(if $(DEFCONFIG),$(DEFCONFIG),$(CONFIG_DIR)/defconfig) \
                $(CONFIG_CONFIG_IN)
-       @$(SED) '/BR2_DEFCONFIG=/d' $(if $(DEFCONFIG),$(DEFCONFIG),$(CONFIG_DIR)/defconfig)
+       @$(SED) '/BR2_DEFCONFIG=/d' \
+               -e '/BR2_DL_DIR=/d' \
+               $(if $(DEFCONFIG),$(DEFCONFIG),$(CONFIG_DIR)/defconfig)
 
 .PHONY: defconfig savedefconfig update-defconfig