civetweb: fix build for xtensa
authorBaruch Siach <baruch@tkos.co.il>
Tue, 31 Dec 2013 09:07:31 +0000 (11:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 31 Dec 2013 10:57:54 +0000 (11:57 +0100)
The civetweb package bundled sqlite3 generates an object that is too large for
the xtensa default placement of literals in a dedicated section. Use
-mtext-section-literal to place literals in the text section.

Fixes
http://autobuild.buildroot.net/results/d14/d142f3ce17ab22cc39f9117c114318c1b5cadfc5/.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/civetweb/civetweb.mk

index 4c8f4e88fbb9904396635ae3cc0e95a3d961044b..b950890608a1822226a584b0bb14ffc3b7edd749 100644 (file)
@@ -25,6 +25,9 @@ endif
 
 ifeq ($(BR2_CIVETWEB_WITH_LUA),y)
        CIVETWEB_CONF_OPT += WITH_LUA=1
+ifeq ($(BR2_xtensa),y)
+       CIVETWEB_COPT += -mtext-section-literals
+endif
 endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)