Revert "packages infra: add function to get a Kconfig option"
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Mar 2014 18:16:46 +0000 (19:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Mar 2014 18:16:46 +0000 (19:16 +0100)
This reverts commit c28a28eed1943c1efb958448a87a2e8f0baf48d6. The
whole host-lzop optional dependency logic cannot work, since the
configuration file will only be known after the kernel sources are
extracted, if an internal kernel defconfig is used, which is quite
common.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-utils.mk

index 99fefe6a448eb17ac912228940fcc7cfa59f9e41..91a198160fd4bad3f74f05bae27ead73376963d9 100644 (file)
@@ -52,8 +52,6 @@ define KCONFIG_DISABLE_OPT
        echo "# $(1) is not set" >> $(2)
 endef
 
-KCONFIG_GET_OPT = $(shell sed -e 's/^$(1)=//p' $(2))
-
 # Helper functions to determine the name of a package and its
 # directory from its makefile directory, using the $(MAKEFILE_LIST)
 # variable provided by make. This is used by the *TARGETS macros to