python: remove idle sample
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 10 Jul 2013 18:39:17 +0000 (15:39 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 10 Jul 2013 19:56:44 +0000 (21:56 +0200)
Also move smtpd.py removal to the global remove useless files define.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/python/python.mk

index 975d6f40c0d6d77eba76a471b4589259036c07bb..ecea638d43b4bc02dba412547ea6601d56b1e2a9 100644 (file)
@@ -143,21 +143,18 @@ endef
 
 PYTHON_POST_INSTALL_STAGING_HOOKS += PYTHON_FIXUP_LIBDIR
 
-# Bad shebang, normally not used
-define PYTHON_REMOVE_SMTPD
-       rm -f $(TARGET_DIR)/usr/bin/smtpd.py
-endef
-
-PYTHON_POST_INSTALL_TARGET_HOOKS += PYTHON_REMOVE_SMTPD
-
 #
 # Remove useless files. In the config/ directory, only the Makefile
 # and the pyconfig.h files are needed at runtime.
 #
+# idle & smtpd.py have bad shebangs and are mostly samples
+#
 define PYTHON_REMOVE_USELESS_FILES
+       rm -f $(TARGET_DIR)/usr/bin/idle
        rm -f $(TARGET_DIR)/usr/bin/python$(PYTHON_VERSION_MAJOR)-config
        rm -f $(TARGET_DIR)/usr/bin/python2-config
        rm -f $(TARGET_DIR)/usr/bin/python-config
+       rm -f $(TARGET_DIR)/usr/bin/smtpd.py
        for i in `find $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/config/ \
                -type f -not -name pyconfig.h -a -not -name Makefile` ; do \
                rm -f $$i ; \