package/efl: enable elput support
authorRomain Naour <romain.naour@gmail.com>
Wed, 7 Sep 2016 21:08:41 +0000 (23:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Sep 2016 16:26:35 +0000 (18:26 +0200)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
[Thomas:
 - add --disable-elput in the !BR2_PACKAGE_EFL_ELPUT case
 - add missing dependency on libxkbcomm]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/Config.in
package/efl/efl.mk

index fa6d7617e51fe48648430f9681bb999f3583c8e8..f963ade8e5605d76e3c609174e2699858a901200 100644 (file)
@@ -183,6 +183,16 @@ config BR2_PACKAGE_EFL_OPENGL_NONE
 
 endchoice # OpenGL support
 
+config BR2_PACKAGE_EFL_ELPUT
+       bool "Elput"
+       select BR2_PACKAGE_LIBINPUT
+       select BR2_PACKAGE_LIBXKBCOMMON
+       help
+         The elput library is an efl abstraction for the libinput library
+         which can be used by various other subsystems (ecore_fb,
+         ecore_drm, etc) to handle interfacing with libinput without
+         having to duplicate the code in each subsystem.
+
 comment "libevas loaders"
 
 config BR2_PACKAGE_EFL_PNG
index 853c9dcb56cb524b72e55788f2f4076e090c6370..80387393fe6e9fe622209fd86fef18be6c26589c 100644 (file)
@@ -152,6 +152,13 @@ else
 EFL_CONF_OPTS += --disable-wayland
 endif
 
+ifeq ($(BR2_PACKAGE_EFL_ELPUT),y)
+EFL_CONF_OPTS += --enable-elput
+EFL_DEPENDENCIES += libinput libxkbcommon
+else
+EFL_CONF_OPTS += --disable-elput
+endif
+
 ifeq ($(BR2_PACKAGE_EFL_FB),y)
 EFL_CONF_OPTS += --enable-fb
 else