jffs2: let makedevs create device files
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 5 Jun 2010 15:18:40 +0000 (17:18 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 5 Jun 2010 19:23:28 +0000 (21:23 +0200)
The common filesystem infrastructure in fs/common.mk uses a smart
combination of makedevs and fakeroot to create the device files in the
target filesystem images without being root. This technique is applied
to all filesystem formats that rely on this common infrastructure, and
JFFS2 is one of them.

Therefore, using the -D option of mkfs.jffs2, which allows to specify
a device table, is redundant with the usage of makedevs. And it is
worst than redundant: for some reason, -D does not create all device
files with the correct major and minor numbers, as reported in
bug #1771.

For coherence, we just remove the usage of mkfs.jffs2 -D option, and
rely on makedevs/fakeroot to create the device files.

This commit fixes bug #1771.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
fs/jffs2/jffs2.mk

diff --git a/CHANGES b/CHANGES
index 6fddc140defb6dd84065469d01abe21e6f83b24c..a3a52035c3bcd5b945c45f81c0aff239d517ae4b 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -8,6 +8,7 @@
 
        Issues resolved (http://bugs.uclibc.org):
 
+       #1771: Fakeroot and the target/generic/device_table.txt create bad...
        #1909: netperf-2.4.5 fails to build because of undeclared SOCK_DCCP
 
 2010.05, Released May 30th, 2010:
index 36be03741cc3f0707dfb06e6203802c37e1265bc..fd5da0c1b6484db3d68d90ec282e50f2cc95fd84 100644 (file)
@@ -32,10 +32,6 @@ JFFS2_OPTS += -n
 SUMTOOL_OPTS += -n
 endif
 
-ifneq ($(ROOTFS_DEVICE_TABLE),)
-JFFS2_OPTS += -D $(ROOTFS_DEVICE_TABLE)
-endif
-
 ROOTFS_JFFS2_DEPENDENCIES = host-mtd
 
 ifneq ($(BR2_TARGET_ROOTFS_JFFS2_SUMMARY),)