system: introduce BR2_SYSTEM_DEFAULT_PATH option
authorMarkus Mayer <mmayer@broadcom.com>
Thu, 20 Dec 2018 17:58:11 +0000 (09:58 -0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 31 Dec 2018 13:32:20 +0000 (14:32 +0100)
The configuration option BR2_SYSTEM_DEFAULT_PATH allows the user to
override the default path, which can be used by /etc/profile and some
system daemons.

It defaults to the value previously hard-coded in /etc/profile. This
default should be suitable for most users.

Signed-off-by: Markus Mayer <mmayer@broadcom.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
system/Config.in
system/system.mk

index 0f77b9b6721a14144395ff057489238cf0f551c5..9941807e5d9ba3b543380c705251861a851757f2 100644 (file)
@@ -386,6 +386,16 @@ comment "automatic network configuration via DHCP needs ifupdown or busybox or n
 
 endif # BR2_ROOTFS_SKELETON_DEFAULT
 
+config BR2_SYSTEM_DEFAULT_PATH
+       string "Set the system's default PATH"
+       default "/bin:/sbin:/usr/bin:/usr/sbin"
+       help
+         Sets the system's default PATH. It is being used in
+         /etc/profile in the skeleton-init-common package and by some
+         daemons.
+
+         The default should work in most cases.
+
 config BR2_ENABLE_LOCALE_PURGE
        bool "Purge unwanted locales"
        default y
index ca6bf1388f393f0d37f826623e42f17bffaf3924..8db87cb12930bbc656645f531c2eb26d81d74c86 100644 (file)
@@ -86,3 +86,7 @@ define SYSTEM_REMOUNT_ROOT_INITTAB
        $(SED) '/^[^#].*-o remount,rw \/$$/s~^~#~' $(TARGET_DIR)/etc/inittab
 endef
 endif
+
+ifeq ($(BR_BUILDING)$(BR2_SYSTEM_DEFAULT_PATH),y"")
+$(error BR2_SYSTEM_DEFAULT_PATH can't be empty)
+endif