package/samba4: Change tmpfiles path
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Sat, 2 Jul 2016 16:21:31 +0000 (18:21 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jul 2016 16:50:36 +0000 (18:50 +0200)
Per the documentation:
https://www.freedesktop.org/software/systemd/man/tmpfiles.d.html

The order of path by priorites is:
/etc/tmpfiles.d/*.conf
/run/tmpfiles.d/*.conf
/usr/lib/tmpfiles.d/*.conf

For the user to be able to override our tmpfiles easily, it's better to
place our files in /usr/lib/tmpfiles.d/

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/samba4/samba4.mk

index 9f2bb0db042d2f40b0728fd09eeebafdfb86026d..9ac72f55305700f989ca956d638ce8aa2fd5e73e 100644 (file)
@@ -156,8 +156,8 @@ define SAMBA4_INSTALL_INIT_SYSTEMD
        ln -sf ../../../../usr/lib/systemd/system/winbind.service \
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/winbind.service
        $(INSTALL) -D -m 644 $(@D)/packaging/systemd/samba.conf.tmp \
-               $(TARGET_DIR)/etc/tmpfiles.d/samba.conf
-       printf "d /var/log/samba  755 root root\n" >>$(TARGET_DIR)/etc/tmpfiles.d/samba.conf
+               $(TARGET_DIR)/usr/lib/tmpfiles.d/samba.conf
+       printf "d /var/log/samba  755 root root\n" >>$(TARGET_DIR)/usr/lib/tmpfiles.d/samba.conf
 endef
 
 $(eval $(generic-package))