Qt: add config option to build libQtDeclarative module
authorDaniel Mack <zonque@gmail.com>
Tue, 31 May 2011 16:16:34 +0000 (18:16 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 20 Jun 2011 09:50:43 +0000 (11:50 +0200)
Signed-off-by: Daniel Mack <zonque@gmail.com>
Acked-by: Daniel Nyström <daniel.nystrom@timeterminal.se>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/Config.in
package/qt/qt.mk

index 4a3945c82b4e79c82e5f24c5b477f3170898c324..214f14090479ae941bd5e1d55182b522b99a638c 100644 (file)
@@ -378,4 +378,11 @@ config BR2_PACKAGE_QT_SCRIPTTOOLS
          Build the Qt Script Tools module.
          if unsure, say n.
 
+config BR2_PACKAGE_QT_DECLARATIVE
+       bool "Declarative module"
+       depends on BR2_PACKAGE_QT_GUI_MODULE
+       help
+         Build the Qt Declarative Module for qml support
+         if unsure, say n.
+
 endif # BR2_PACKAGE_QT
index 8bcbd3fef824840fdff7844dd5c289ca901139d1..e8b7a496410014959aafdd42ef85b6b7623b52d2 100644 (file)
@@ -398,6 +398,12 @@ else
 QT_CONFIGURE_OPTS += -no-stl
 endif
 
+ifeq ($(BR2_PACKAGE_QT_DECLARATIVE),y)
+QT_CONFIGURE_OPTS += -declarative
+else
+QT_CONFIGURE_OPTS += -no-declarative
+endif
+
 # ccache and precompiled headers don't play well together
 ifeq ($(BR2_CCACHE),y)
 QT_CONFIGURE_OPTS += -no-pch
@@ -535,6 +541,9 @@ endif
 ifeq ($(BR2_PACKAGE_QT_SCRIPTTOOLS),y)
 QT_INSTALL_LIBS    += QtScriptTools
 endif
+ifeq ($(BR2_PACKAGE_QT_DECLARATIVE),y)
+QT_INSTALL_LIBS    += QtDeclarative
+endif
 ifeq ($(BR2_PACKAGE_QT_QT3SUPPORT),y)
 QT_INSTALL_LIBS    += Qt3Support
 endif